summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Kehrer <paul.l.kehrer@gmail.com>2020-08-01 14:02:11 -0500
committerGitHub <noreply@github.com>2020-08-01 15:02:11 -0400
commit385e33f3f39cfeb132f31e0d1c892cca41c38c14 (patch)
treeae8f09693de265835febc1eac414b0d6ce25fbf2
parent9ec889b99a7d960b971caec9e6a95e1bb64a768d (diff)
downloadpy-bcrypt-git-385e33f3f39cfeb132f31e0d1c892cca41c38c14.tar.gz
use pip wheel for aarch64 as well (#210)
* use pip wheel for aarch64 as well * downgrade pip
-rw-r--r--.github/workflows/wheel-builder.yml3
1 files changed, 2 insertions, 1 deletions
diff --git a/.github/workflows/wheel-builder.yml b/.github/workflows/wheel-builder.yml
index d905618..82727fc 100644
--- a/.github/workflows/wheel-builder.yml
+++ b/.github/workflows/wheel-builder.yml
@@ -133,12 +133,13 @@ jobs:
args: |
bash -c "/opt/python/${{ matrix.PYTHON }}/bin/pip install virtualenv;
/opt/python/${{ matrix.PYTHON }}/bin/python -m virtualenv .venv;
+ .venv/bin/pip install -U pip==10.0.1 # downgrade pip for reasons we can't remember but are definitely needed
.venv/bin/pip install setuptools wheel cffi six;
REGEX='cp3([0-9])*';
if [[ ${{ matrix.PYTHON }} =~ $REGEX ]]; then
PY_LIMITED_API=\"--py-limited-api=cp3${BASH_REMATCH[1]}\";
fi;
- .venv/bin/python setup.py bdist_wheel $PY_LIMITED_API -d tmpwheelhouse;
+ .venv/bin/pip wheel bcrypt --no-binary bcrypt --no-deps --wheel-dir=tmpwheelhouse $PY_LIMITED_API
auditwheel repair tmpwheelhouse/bcrypt*.whl -w wheelhouse/;
.venv/bin/pip install bcrypt --no-index -f wheelhouse/;
.venv/bin/python -c \"import bcrypt; password = b'super secret password';hashed = bcrypt.hashpw(password, bcrypt.gensalt());bcrypt.checkpw(password, hashed)\";"