summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml83
1 files changed, 0 insertions, 83 deletions
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index 6aef248..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,83 +0,0 @@
-language: python
-sudo: required
-dist: bionic
-cache: pip
-python:
- - '3.6'
- - '3.7'
- - '3.8'
- - 'pypy3.6-7.3.1'
-
-env:
- global:
- PYTHONUNBUFFERED=yes
- matrix:
- - MATRIX_TOXENV=unit
-
-stages:
- - test
- - integration
- - lint
-
-_integration_job: &integration_job
- script:
- - docker build -t rabbitmq:tls .
- - tox -v -- -v
- services:
- - docker
- stage: integration
-
-matrix:
- fast_finish: true
- include:
- - python: 3.8
- env: TOXENV=flake8
- stage: lint
- - python: 3.8
- env: TOXENV=pydocstyle
- stage: lint
- - python: 3.8
- env: TOXENV=apicheck
- stage: lint
- - python: 3.6
- <<: *integration_job
- env: MATRIX_TOXENV=integration-rabbitmq
- - python: 3.7
- <<: *integration_job
- env: MATRIX_TOXENV=integration-rabbitmq
- - python: 3.8
- <<: *integration_job
- env: MATRIX_TOXENV=integration-rabbitmq
- services:
- - docker
- stage: integration
- - python: pypy3.6-7.3.1
- <<: *integration_job
- env: MATRIX_TOXENV=integration-rabbitmq
- - python: 3.6
- <<: *integration_job
- env: MATRIX_TOXENV=integration-rabbitmq CELERY_ENABLE_SPEEDUPS=1
- - python: 3.7
- <<: *integration_job
- env: MATRIX_TOXENV=integration-rabbitmq CELERY_ENABLE_SPEEDUPS=1
- - python: 3.8
- <<: *integration_job
- env: MATRIX_TOXENV=integration-rabbitmq CELERY_ENABLE_SPEEDUPS=1
-
-
-before_install:
- - if [[ -v MATRIX_TOXENV ]]; then export TOXENV=${TRAVIS_PYTHON_VERSION}-${MATRIX_TOXENV}; fi; env
-install:
- - pip --disable-pip-version-check install -U pip setuptools wheel | cat
- - pip --disable-pip-version-check install -U --upgrade-strategy eager tox tox-docker | cat
- - python setup.py develop
-script: tox -v -- -v
-after_success:
- - .tox/$TRAVIS_PYTHON_VERSION/bin/coverage xml
- - .tox/$TRAVIS_PYTHON_VERSION/bin/codecov -e TOXENV
-notifications:
- irc:
- channels:
- - "chat.freenode.net#celery"
- on_success: change
- on_failure: change