summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatus Valo <matusvalo@users.noreply.github.com>2020-04-17 15:51:34 +0200
committerGitHub <noreply@github.com>2020-04-17 19:51:34 +0600
commitace59527c8dd74888590e2a99a0bec8f26dfc1b7 (patch)
treedf4921398a251494180a03038a3ef403f8ef9bfc
parent0416761daf88a8fdd60454b2515242be83d783c0 (diff)
downloadpy-amqp-ace59527c8dd74888590e2a99a0bec8f26dfc1b7.tar.gz
Add Speedups section to README.rst (#313)
-rw-r--r--README.rst16
1 files changed, 16 insertions, 0 deletions
diff --git a/README.rst b/README.rst
index 77e6eca..f05f3a3 100644
--- a/README.rst
+++ b/README.rst
@@ -138,6 +138,22 @@ Consumer with acknowledgments disabled:
while True:
c.drain_events()
+Speedups
+========
+
+This library has **experimental** support of speedups. Speedups are implemented using Cython. To enable speedups, ``CELERY_ENABLE_SPEEDUPS`` environment variable must be set during building/installation.
+Currently speedups can be installed:
+
+1. using source package (using ``--no-binary`` switch):
+
+.. code-block::
+CELERY_ENABLE_SPEEDUPS=true pip install --no-binary :all: amqp
+
+
+2. building directly source code:
+
+.. code-block::
+CELERY_ENABLE_SPEEDUPS=true python setup.py install
Further
=======