summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Dufresne <jon.dufresne@gmail.com>2017-04-16 10:44:11 -0700
committerAsif Saifuddin Auvi <auvipy@users.noreply.github.com>2017-04-16 23:44:11 +0600
commitebef8e06ebf77683f2cfc5a396d70dc86a4ce2d5 (patch)
tree9e8dcd7f8e51bb8f134925abd3cfb4fadc586f4a
parent7b863bc0fc778cedbc02f09e69619e65047fe3b0 (diff)
downloadpy-amqp-ebef8e06ebf77683f2cfc5a396d70dc86a4ce2d5.tar.gz
Document and test all supported Python versions (#140)
-rw-r--r--.travis.yml29
-rw-r--r--appveyor.yml17
-rw-r--r--setup.py2
-rw-r--r--tox.ini4
4 files changed, 41 insertions, 11 deletions
diff --git a/.travis.yml b/.travis.yml
index e03ba89..4c99ee7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -3,21 +3,32 @@ sudo: false
cache: pip
python:
- '3.5'
+
env:
global:
PYTHONUNBUFFERED=yes
- matrix:
- - TOXENV=2.7
- - TOXENV=3.4
- - TOXENV=pypy
- - TOXENV=3.5
- - TOXENV=flake8
- - TOXENV=flakeplus
- - TOXENV=pydocstyle
- - TOXENV=apicheck
matrix:
fast_finish: true
+ include:
+ - python: 2.7
+ env: TOXENV=2.7
+ - python: pypy
+ env: TOXENV=pypy
+ - python: 3.4
+ env: TOXENV=3.4
+ - python: 3.5
+ env: TOXENV=3.5
+ - python: 3.6
+ env: TOXENV=3.6
+ - python: 2.7
+ env: TOXENV=flake8
+ - python: 2.7
+ env: TOXENV=flakeplus
+ - python: 2.7
+ env: TOXENV=pydocstyle
+ - python: 2.7
+ env: TOXENV=apicheck
install: travis_retry pip install -U tox
script: tox -v -- -v
diff --git a/appveyor.yml b/appveyor.yml
index 8677155..0a1bddd 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -20,6 +20,14 @@ environment:
PYTHON_VERSION: "3.4.x"
PYTHON_ARCH: "32"
+ - PYTHON: "C:\\Python35"
+ PYTHON_VERSION: "3.5.x"
+ PYTHON_ARCH: "32"
+
+ - PYTHON: "C:\\Python36"
+ PYTHON_VERSION: "3.6.x"
+ PYTHON_ARCH: "32"
+
- PYTHON: "C:\\Python27-x64"
PYTHON_VERSION: "2.7.x"
PYTHON_ARCH: "64"
@@ -30,6 +38,15 @@ environment:
PYTHON_ARCH: "64"
WINDOWS_SDK_VERSION: "v7.1"
+ - PYTHON: "C:\\Python35-x64"
+ PYTHON_VERSION: "3.5.x"
+ PYTHON_ARCH: "64"
+ WINDOWS_SDK_VERSION: "v7.1"
+
+ - PYTHON: "C:\\Python36-x64"
+ PYTHON_VERSION: "3.6.x"
+ PYTHON_ARCH: "64"
+ WINDOWS_SDK_VERSION: "v7.1"
init:
- "ECHO %PYTHON% %PYTHON_VERSION% %PYTHON_ARCH%"
diff --git a/setup.py b/setup.py
index 03c987e..2899f1a 100644
--- a/setup.py
+++ b/setup.py
@@ -22,9 +22,9 @@ classes = """
Programming Language :: Python :: 2
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
- Programming Language :: Python :: 3.3
Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
+ Programming Language :: Python :: 3.6
License :: OSI Approved :: BSD License
Intended Audience :: Developers
Operating System :: OS Independent
diff --git a/tox.ini b/tox.ini
index 3156037..1c99e9c 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,6 +4,7 @@ envlist =
pypy
3.4
3.5
+ 3.6
flake8
flakeplus
apicheck
@@ -23,9 +24,10 @@ commands = py.test -xv --cov=amqp --cov-report=xml --no-cov-on-fail
basepython =
2.7,flakeplus,flake8,apicheck,linkcheck,pydocstyle: python2.7
+ pypy: pypy
3.4: python3.4
3.5: python3.5
- pypy: pypy
+ 3.6: python3.6
[testenv:apicheck]
commands =