summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatus Valo <matusvalo@gmail.com>2019-02-15 05:15:54 -0800
committerMatus Valo <matusvalo@gmail.com>2019-02-15 05:15:54 -0800
commitfed63d187f29e18b83b27f217c4ec99eb24d0d03 (patch)
tree5797e54e9750483fcc752c44959785fdba90215e
parent093cdb2e28caad08d14abf4e9ca5501082875a6f (diff)
downloadpy-amqp-fed63d187f29e18b83b27f217c4ec99eb24d0d03.tar.gz
Fix broken setup.py test --pytest-args
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 86ffd0b..3d3d9e4 100644
--- a/setup.py
+++ b/setup.py
@@ -94,11 +94,12 @@ class pytest(setuptools.command.test.test):
def initialize_options(self):
setuptools.command.test.test.initialize_options(self)
- self.pytest_args = []
+ self.pytest_args = ''
def run_tests(self):
import pytest
- sys.exit(pytest.main(self.pytest_args))
+ pytest_args = self.pytest_args.split(' ')
+ sys.exit(pytest.main(pytest_args))
setuptools.setup(
name=NAME,