summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremiah Cooper <JCooper@jeremiahcooper.com>2019-03-01 19:03:16 -0500
committerMatus Valo <matusvalo@users.noreply.github.com>2019-03-02 01:03:16 +0100
commite3bf8c2c39388567d7105a41616b346d3992ffa8 (patch)
tree7f585036e7ccf38c988d517e61ac3ef77523bf48
parent228159d67abd56234ae70f2c39741979d85ea3bd (diff)
downloadpy-amqp-e3bf8c2c39388567d7105a41616b346d3992ffa8.tar.gz
Adds Python 3.7 to the list of supported languages in setup.py and adds Python 3.7 to Appveyor configuration. (#261)
-rw-r--r--appveyor.yml9
-rw-r--r--setup.py1
2 files changed, 10 insertions, 0 deletions
diff --git a/appveyor.yml b/appveyor.yml
index 0a1bddd..799a51f 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -28,6 +28,10 @@ environment:
PYTHON_VERSION: "3.6.x"
PYTHON_ARCH: "32"
+ - PYTHON: "C:\\Python37"
+ PYTHON_VERSION: "3.7.x"
+ PYTHON_ARCH: "32"
+
- PYTHON: "C:\\Python27-x64"
PYTHON_VERSION: "2.7.x"
PYTHON_ARCH: "64"
@@ -48,6 +52,11 @@ environment:
PYTHON_ARCH: "64"
WINDOWS_SDK_VERSION: "v7.1"
+ - PYTHON: "C:\\Python37-x64"
+ PYTHON_VERSION: "3.7.x"
+ PYTHON_ARCH: "64"
+ WINDOWS_SDK_VERSION: "v7.1"
+
init:
- "ECHO %PYTHON% %PYTHON_VERSION% %PYTHON_ARCH%"
diff --git a/setup.py b/setup.py
index 3d3d9e4..12d6e62 100644
--- a/setup.py
+++ b/setup.py
@@ -25,6 +25,7 @@ classes = """
Programming Language :: Python :: 3.4
Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
License :: OSI Approved :: BSD License
Intended Audience :: Developers
Operating System :: OS Independent