summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniele Varrazzo <daniele.varrazzo@gmail.com>2021-06-30 14:52:27 +0100
committerDaniele Varrazzo <daniele.varrazzo@gmail.com>2021-06-30 14:52:27 +0100
commit39f12bbfc529f16e28fc8b03dd4162bdfd85b10f (patch)
tree71d47be4bd88c31cdda2a48fdd8eeaa8c000ddf3
parent47b93efcf8fb4aa2de12fb1e690b87a1e73515da (diff)
downloadpsycopg2-39f12bbfc529f16e28fc8b03dd4162bdfd85b10f.tar.gz
Don't build .exe packages anymore
-rw-r--r--.appveyor/packages.yml2
-rw-r--r--doc/release.rst5
-rwxr-xr-xscripts/build/appveyor.py6
3 files changed, 1 insertions, 12 deletions
diff --git a/.appveyor/packages.yml b/.appveyor/packages.yml
index db6ccd5..c15788e 100644
--- a/.appveyor/packages.yml
+++ b/.appveyor/packages.yml
@@ -81,8 +81,6 @@ test_script:
artifacts:
- path: dist\psycopg2-*\*.whl
name: wheel
- - path: dist\psycopg2-*\*.exe
- name: exe
# vim: set ts=4 sts=4 sw=4:
diff --git a/doc/release.rst b/doc/release.rst
index a49ec7e..088bfa4 100644
--- a/doc/release.rst
+++ b/doc/release.rst
@@ -54,11 +54,6 @@ How to make a psycopg2 release
``scripts/build`` directory. They will be saved in a
``packages/psycopg2-${VERSION}`` directory.
-- Remove the ``.exe`` from the dir, because we don't want to upload them on
- PyPI::
-
- $ rm -v packages/psycopg2-${VERSION}/*.exe
-
- Only for stable packages: upload the signed packages on PyPI::
$ twine upload -s packages/psycopg2-${VERSION}/*
diff --git a/scripts/build/appveyor.py b/scripts/build/appveyor.py
index 39b3ebe..d16c08a 100755
--- a/scripts/build/appveyor.py
+++ b/scripts/build/appveyor.py
@@ -321,15 +321,11 @@ def patch_package_name():
def build_binary_packages():
- """Create wheel/exe binary packages."""
+ """Create wheel binary packages."""
os.chdir(opt.package_dir)
add_pg_config_path()
- # Build .exe packages for whom still use them
- if opt.package_name == 'psycopg2':
- run_python(['setup.py', 'bdist_wininst', "-d", opt.dist_dir])
-
# Build .whl packages
run_python(['setup.py', 'bdist_wheel', "-d", opt.dist_dir])