summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-12-17 21:52:01 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2020-12-17 21:52:01 +0100
commit2fe7181a8a1d1b0564790238e67bbe43ad41b9e8 (patch)
tree0b15b272ce52254d67ac60ee651e9b4a4c86ff9b
parent60475128881f3c89608dfc45e62bf3872c32a427 (diff)
parentdd60ea1c97999f139cace6541db493de6b494d10 (diff)
downloadpsutil-2fe7181a8a1d1b0564790238e67bbe43ad41b9e8.tar.gz
merge from branch
Signed-off-by: Giampaolo Rodola <g.rodola@gmail.com>
-rw-r--r--.github/workflows/build.yml (renamed from .github/workflows/ci.yml)23
-rw-r--r--appveyor.yml2
2 files changed, 17 insertions, 8 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/build.yml
index c93ad480..c8a98f79 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/build.yml
@@ -9,8 +9,8 @@
# To skip certain builds see:
# https://cibuildwheel.readthedocs.io/en/stable/options/#build-skip
-name: CI
on: [push]
+name: Build
jobs:
linux-macos-win:
name: ${{ matrix.os }}
@@ -25,10 +25,8 @@ jobs:
- {name: Linux, python: '3.9', os: ubuntu-latest}
env:
CIBW_TEST_COMMAND:
- PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_TESTING=1 PSUTIL_DEBUG=1
- python {project}/psutil/tests/runner.py &&
- PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_TESTING=1 PSUTIL_DEBUG=1
- python {project}/psutil/tests/test_memleaks.py
+ PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_TESTING=1 PSUTIL_DEBUG=1 python {project}/psutil/tests/runner.py &&
+ PYTHONWARNINGS=always PYTHONUNBUFFERED=1 PSUTIL_TESTING=1 PSUTIL_DEBUG=1 python {project}/psutil/tests/test_memleaks.py
CIBW_TEST_EXTRAS: test
CIBW_SKIP: cp35-* pp*
steps:
@@ -51,7 +49,6 @@ jobs:
run: |
pip install cibuildwheel
cibuildwheel .
-
- name: Create wheels
uses: actions/upload-artifact@v2
with:
@@ -86,10 +83,22 @@ jobs:
set +e
export \
PYTHONWARNINGS=always \
- PYTHONUNBUFFERED=1 \
PSUTIL_TESTING=1 \
PSUTIL_DEBUG=1
python3 -m pip install --user setuptools
python3 setup.py install
python3 psutil/tests/runner.py
python3 psutil/tests/test_memleaks.py
+
+ linters:
+ runs-on: ubuntu-latest
+ steps:
+ - uses: actions/checkout@v2
+ - uses: actions/setup-python@v2
+ - name: 'Linters'
+ run: |
+ python -m pip install flake8
+ python -m flake8 .
+ echo "flake8 linting OK"
+ find . -type f \( -iname "*.c" -o -iname "*.h" \) | xargs python scripts/internal/clinter.py
+ echo "C linting OK"
diff --git a/appveyor.yml b/appveyor.yml
index a0532206..aaf7de30 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -99,7 +99,7 @@ cache:
# - might want to upload the content of dist/*.whl to a public wheelhouse
skip_commits:
- message: skip-ci
+ message: skip-appveyor
# run build only if one of the following files is modified on commit
only_commits: