summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2020-02-19 22:54:40 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2020-02-19 22:54:40 +0100
commit79b8d2a0a47c3c58263a54f3511a47b3db32dc56 (patch)
tree406ac36b8bf79f8303c7d4efe344f08cfb77e02b
parentaa495a2fc430144ae630a62cfc0e9a4dc57aefd5 (diff)
parent9b8b843c9ae9aa7a07b551e3666f334ff9a1cb3d (diff)
downloadpsutil-79b8d2a0a47c3c58263a54f3511a47b3db32dc56.tar.gz
merge from upstream
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5c4d5b70..d1e4dec9 100644
--- a/Makefile
+++ b/Makefile
@@ -29,6 +29,11 @@ DEPS += `$(PYTHON) -c \
INSTALL_OPTS = `$(PYTHON) -c \
"import sys; print('' if hasattr(sys, 'real_prefix') else '--user')"`
TEST_PREFIX = PYTHONWARNINGS=all PSUTIL_TESTING=1 PSUTIL_DEBUG=1
+FLAKE8_ARGS = --per-file-ignores='\
+ setup.py:T001 \
+ scripts/*:T001 \
+ psutil/tests/runner.py:T001 \
+ psutil/tests/test_memory_leaks.py:T001'
all: test
@@ -171,7 +176,11 @@ test-coverage: ## Run test coverage.
# ===================================================================
lint-py: ## Run Python (flake8) linter.
+<<<<<<< HEAD
@git ls-files '*.py' | xargs $(PYTHON) -m flake8 --config=.flake8
+=======
+ @git ls-files '*.py' | xargs $(PYTHON) -m flake8 $(FLAKE8_ARGS)
+>>>>>>> 9b8b843c9ae9aa7a07b551e3666f334ff9a1cb3d
lint-c: ## Run C linter.
@git ls-files '*.c' '*.h' | xargs $(PYTHON) scripts/internal/clinter.py