summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2015-01-06 07:30:12 -0800
committerGiampaolo Rodola <g.rodola@gmail.com>2015-01-06 07:30:12 -0800
commitea6e3d7cbc47e6b49b7cbff83575fe7254dc8a4d (patch)
tree87efeedde0d93d84f14d5bb5ffaa86d06df8068b
parent97fba78f6b8bf39176ea98188f668f761b1d1281 (diff)
downloadpsutil-ea6e3d7cbc47e6b49b7cbff83575fe7254dc8a4d.tar.gz
windows: remove last python 2.4/2.5 references from make.bat; update dates
-rw-r--r--HISTORY.rst2
-rw-r--r--README.rst1
-rw-r--r--make.bat7
3 files changed, 3 insertions, 7 deletions
diff --git a/HISTORY.rst b/HISTORY.rst
index 334c7623..e053b8d5 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -1,6 +1,6 @@
Bug tracker at https://github.com/giampaolo/psutil/issues
-2.2.0 - XXXX-XX-XX
+2.2.0 - 2015-01-06
==================
**Enhancements**
diff --git a/README.rst b/README.rst
index 405785ca..3a218705 100644
--- a/README.rst
+++ b/README.rst
@@ -320,6 +320,7 @@ http://groups.google.com/group/psutil/
Timeline
========
+- 2015-01-06: `psutil-2.2.0.tar.gz <https://pypi.python.org/packages/source/p/psutil/psutil-2.2.0.tar.gz>`_
- 2014-09-26: `psutil-2.1.3.tar.gz <https://pypi.python.org/packages/source/p/psutil/psutil-2.1.3.tar.gz>`_
- 2014-09-21: `psutil-2.1.2.tar.gz <https://pypi.python.org/packages/source/p/psutil/psutil-2.1.2.tar.gz>`_
- 2014-04-30: `psutil-2.1.1.tar.gz <https://pypi.python.org/packages/source/p/psutil/psutil-2.1.1.tar.gz>`_
diff --git a/make.bat b/make.bat
index 24e5c7e3..febf7d2f 100644
--- a/make.bat
+++ b/make.bat
@@ -41,9 +41,9 @@ if "%1" == "help" (
echo build-wheels create wheel installers in dist directory
echo clean clean build files
echo install compile and install
- echo memtest run memory leak tests
echo setup-env install pip, unittest2, wheels for all python versions
echo test run tests
+ echo test-memleaks run memory leak tests
echo test-process run process related tests
echo test-system run system APIs related tests
echo uninstall uninstall
@@ -132,9 +132,6 @@ if "%1" == "test-memleaks" (
if "%1" == "build-exes" (
:build-exes
- rem mingw 32 versions
- C:\Python24\python.exe setup.py build -c mingw32 bdist_wininst || goto :error
- C:\Python25\python.exe setup.py build -c mingw32 bdist_wininst || goto :error
rem "standard" 32 bit versions, using VS 2008 (2.6, 2.7) or VS 2010 (3.3+)
C:\Python26\python.exe setup.py build bdist_wininst || goto :error
C:\Python27\python.exe setup.py build bdist_wininst || goto :error
@@ -154,8 +151,6 @@ if "%1" == "build-exes" (
if "%1" == "upload-exes" (
:upload-exes
- rem mingw 32 versions
- C:\Python25\python.exe setup.py build -c mingw32 bdist_wininst upload || goto :error
rem "standard" 32 bit versions, using VS 2008 (2.6, 2.7) or VS 2010 (3.3+)
C:\Python26\python.exe setup.py bdist_wininst upload || goto :error
C:\Python27\python.exe setup.py bdist_wininst upload || goto :error