summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2015-06-18 03:48:03 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2015-06-18 03:48:03 +0200
commit6a7d1db1e6dcbef4d172f94d16c6e4903e1fb3d7 (patch)
treee5984cc2df76bd5cb5def52bf5dcad09c99cbec8
parent02baf30d1ccbb963821fb6f80addc2f3cc00acfd (diff)
downloadpsutil-6a7d1db1e6dcbef4d172f94d16c6e4903e1fb3d7.tar.gz
PEP8 fixes + update HISTORY/CREDITS
-rw-r--r--CREDITS5
-rw-r--r--HISTORY.rst1
-rw-r--r--Makefile8
-rw-r--r--test/test_psutil.py6
4 files changed, 15 insertions, 5 deletions
diff --git a/CREDITS b/CREDITS
index 432e744d..37c653f2 100644
--- a/CREDITS
+++ b/CREDITS
@@ -303,3 +303,8 @@ N: John Burnett
W: http://www.johnburnett.com/
C: Irvine, CA, US
I: 614
+
+N: Árni Már Jónsson
+E: Reykjavik, Iceland
+E: https://github.com/arnimarj
+I: 634
diff --git a/HISTORY.rst b/HISTORY.rst
index bf694ca4..59036f72 100644
--- a/HISTORY.rst
+++ b/HISTORY.rst
@@ -6,6 +6,7 @@ Bug tracker at https://github.com/giampaolo/psutil/issues
**Bug fixes**
- #632: [Linux] better error message if cannot parse process UNIX connections.
+- #634: [Linux] Proces.cmdline() does not include empty string arguments.
- #635: [UNIX] crash on module import if 'enum' package is installed on python
< 3.4.
diff --git a/Makefile b/Makefile
index 18bc45e1..2c9817a9 100644
--- a/Makefile
+++ b/Makefile
@@ -45,17 +45,19 @@ install-dev-deps:
rm /tmp/get-pip.py
$(PYTHON) -m pip install --user --upgrade pip
$(PYTHON) -m pip install --user --upgrade \
+ # mandatory for unittests
+ ipaddress \
+ mock \
+ unittest2 \
+ # nice to have
coverage \
flake8 \
- ipaddress \
ipdb \
- mock \
nose \
pep8 \
pyflakes \
sphinx \
sphinx-pypi-upload \
- unittest2 \
install: build
$(PYTHON) setup.py install --user; \
diff --git a/test/test_psutil.py b/test/test_psutil.py
index 14b5187e..b93cd863 100644
--- a/test/test_psutil.py
+++ b/test/test_psutil.py
@@ -1558,13 +1558,15 @@ class TestProcess(unittest.TestCase):
with open(c_file, "w") as f:
f.write("void main() { pause(); }")
subprocess.check_call(["gcc", c_file, "-o", funky_name])
- sproc = get_test_subprocess([funky_name, "arg1", "arg2", "", "arg3", ""])
+ sproc = get_test_subprocess(
+ [funky_name, "arg1", "arg2", "", "arg3", ""])
p = psutil.Process(sproc.pid)
# ...in order to try to prevent occasional failures on travis
wait_for_pid(p.pid)
self.assertEqual(p.name(), "foo bar )")
self.assertEqual(p.exe(), "/tmp/foo bar )")
- self.assertEqual(p.cmdline(), ["/tmp/foo bar )", "arg1", "arg2", "", "arg3", ""])
+ self.assertEqual(
+ p.cmdline(), ["/tmp/foo bar )", "arg1", "arg2", "", "arg3", ""])
@unittest.skipUnless(POSIX, 'posix only')
def test_uids(self):