summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2015-06-17 20:41:23 -0700
committerGiampaolo Rodola <g.rodola@gmail.com>2015-06-17 20:41:23 -0700
commit34b41805a9060a16824fa2eb9beb91105e117aee (patch)
tree82dabc49499ca7a3a503fd21b58af1a9eae2c827
parentfcfd37231030f33811996fa5ea44c8b7acfc86b8 (diff)
downloadpsutil-34b41805a9060a16824fa2eb9beb91105e117aee.tar.gz
make.bat refactoring
-rw-r--r--make.bat47
1 files changed, 31 insertions, 16 deletions
diff --git a/make.bat b/make.bat
index 35587fe4..d2f953ea 100644
--- a/make.bat
+++ b/make.bat
@@ -130,7 +130,13 @@ if "%1" == "build-all" (
:build-all
"C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat"
for %%P in (%ALL_PYTHONS%) do (
+ @echo ------------------------------------------------
+ @echo building exe for %%P
+ @echo ------------------------------------------------
%%P setup.py build bdist_wininst || goto :error
+ @echo ------------------------------------------------
+ @echo building wheel for %%P
+ @echo ------------------------------------------------
%%P setup.py build bdist_wheel || goto :error
)
echo OK
@@ -141,7 +147,13 @@ if "%1" == "upload-all" (
:upload-exes
"C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin\vcvars64.bat"
for %%P in (%ALL_PYTHONS%) do (
+ @echo ------------------------------------------------
+ @echo uploading exe for %%P
+ @echo ------------------------------------------------
%%P setup.py build bdist_wininst upload || goto :error
+ @echo ------------------------------------------------
+ @echo uploading wheel for %%P
+ @echo ------------------------------------------------
%%P setup.py build bdist_wheel upload || goto :error
)
echo OK
@@ -150,27 +162,30 @@ if "%1" == "upload-all" (
if "%1" == "setup-env" (
- echo downloading pip installer
+ @echo ------------------------------------------------
+ @echo downloading pip installer
+ @echo ------------------------------------------------
C:\python27\python.exe -c "import urllib2; url = urllib2.urlopen('https://raw.github.com/pypa/pip/master/contrib/get-pip.py'); data = url.read(); f = open('get-pip.py', 'w'); f.write(data)"
- C:\python26\python.exe get-pip.py & C:\python26\scripts\pip install unittest2 wheel ipaddress --upgrade
- C:\python27\python.exe get-pip.py & C:\python27\scripts\pip install wheel ipaddress --upgrade
- C:\python33\python.exe get-pip.py & C:\python33\scripts\pip install wheel ipaddress --upgrade
- C:\python34\scripts\easy_install.exe wheel
- rem 64-bit versions
- C:\python27-64\python.exe get-pip.py & C:\python27-64\scripts\pip install wheel ipaddress --upgrade
- C:\python33-64\python.exe get-pip.py & C:\python33-64\scripts\pip install wheel ipaddress --upgrade
- C:\python34-64\scripts\easy_install.exe wheel
- rem install ipdb only for py 2.7 and 3.4
- C:\python27\scripts\pip install ipdb --upgrade
- C:\python34\scripts\easy_install.exe ipdb
+ for %%P in (%ALL_PYTHONS%) do (
+ @echo ------------------------------------------------
+ @echo installing pip for %%P
+ @echo ------------------------------------------------
+ %%P get-pip.py
+ )
+ for %%P in (%ALL_PYTHONS%) do (
+ @echo ------------------------------------------------
+ @echo building deps for %%P
+ @echo ------------------------------------------------
+ %%P -m pip install unittest2 wheel ipaddress wmi --upgrade
+ )
goto :eof
)
goto :help
:error
- echo ------------------------------------------------
- echo last command exited with error code %errorlevel%
- echo ------------------------------------------------
- exit /b %errorlevel%
+ @echo ------------------------------------------------
+ @echo last command exited with error code %errorlevel%
+ @echo ------------------------------------------------
+ @exit /b %errorlevel%
goto :eof