summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2015-12-26 23:53:08 +0000
committerGiampaolo Rodola <g.rodola@gmail.com>2015-12-26 23:53:08 +0000
commit72195b6e0030cab008e3f28f09af43a4ef0fdb6a (patch)
tree892ba94110eac29f9f6bac433e4bf3952bc82fd3
parent2641bfa55364dd66389803196a7ea3180855a667 (diff)
parent8304c4d050d629381b8762a66c5fc88f505261cd (diff)
downloadpsutil-72195b6e0030cab008e3f28f09af43a4ef0fdb6a.tar.gz
Merge branch 'master' of github.com:giampaolo/psutil
-rw-r--r--MANIFEST.in2
-rw-r--r--docs/index.rst9
-rw-r--r--psutil/__init__.py2
-rw-r--r--psutil/arch/bsd/freebsd.c3
-rw-r--r--setup.py3
5 files changed, 12 insertions, 7 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 3e1db329..bddf43dd 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -16,7 +16,7 @@ include setup.py
include TODO
include tox.ini
recursive-exclude docs/_build *
-recursive-include .ci/ *
+recursive-include .ci *
recursive-include docs *
recursive-include examples *.py
recursive-include psutil *.py *.c *.h
diff --git a/docs/index.rst b/docs/index.rst
index e4ef7946..83adef37 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -8,7 +8,7 @@
Old 1.2.1 documentation is still available
`here <https://code.google.com/p/psutil/wiki/Documentation>`__.
.. versionchanged:: 3.3.0 added support for OpenBSD
-.. versionchanged:: 3.4.0 added support for NetBSD
+.. versionchanged:: 3.4.1 added support for NetBSD
psutil documentation
====================
@@ -39,7 +39,7 @@ From project's home page:
such as: *ps, top, lsof, netstat, ifconfig, who, df, kill, free, nice,
ionice, iostat, iotop, uptime, pidof, tty, taskset, pmap*.
It currently supports **Linux, Windows, OSX, Sun Solaris, FreeBSD, OpenBSD**
- and NetBSD, both **32-bit** and **64-bit** architectures, with Python
+ and **NetBSD**, both **32-bit** and **64-bit** architectures, with Python
versions from **2.6 to 3.5** (users of Python 2.4 and 2.5 may use
`2.1.3 <https://pypi.python.org/pypi?name=psutil&version=2.1.3&:action=files>`__ version).
`PyPy <http://pypy.org/>`__ is also known to work.
@@ -1095,7 +1095,8 @@ Process class
.. warning::
on BSD this method can return files with a 'null' path due to a kernel
- bug (see `issue 595 <https://github.com/giampaolo/psutil/pull/595>`_).
+ bug hence it's not reliable
+ (see `issue 595 <https://github.com/giampaolo/psutil/pull/595>`_).
.. versionchanged:: 3.1.0 no longer hangs on Windows.
@@ -1311,7 +1312,7 @@ Constants
A set of strings representing the status of a process.
Returned by :meth:`psutil.Process.status()`.
- .. versionadded:: 3.4.0: STATUS_SUSPENDED (NetBSD)
+ .. versionadded:: 3.4.1 STATUS_SUSPENDED (NetBSD)
.. _const-conn:
.. data:: CONN_ESTABLISHED
diff --git a/psutil/__init__.py b/psutil/__init__.py
index b97eca42..1c36bee4 100644
--- a/psutil/__init__.py
+++ b/psutil/__init__.py
@@ -1142,7 +1142,7 @@ class Process(object):
class Popen(Process):
- """A more convenient interface to stdlib subprocess module.
+ """A more convenient interface to stdlib subprocess.Popen class.
It starts a sub process and deals with it exactly as when using
subprocess.Popen class but in addition also provides all the
properties and methods of psutil.Process class as a unified
diff --git a/psutil/arch/bsd/freebsd.c b/psutil/arch/bsd/freebsd.c
index 94a1001c..3b7fc478 100644
--- a/psutil/arch/bsd/freebsd.c
+++ b/psutil/arch/bsd/freebsd.c
@@ -473,7 +473,8 @@ error:
*/
PyObject *
psutil_virtual_mem(PyObject *self, PyObject *args) {
- unsigned int total, active, inactive, wired, cached, free;
+ unsigned long total;
+ unsigned int active, inactive, wired, cached, free;
size_t size = sizeof(total);
struct vmtotal vm;
int mib[] = {CTL_VM, VM_METER};
diff --git a/setup.py b/setup.py
index 59f3a167..fb85a8fb 100644
--- a/setup.py
+++ b/setup.py
@@ -245,7 +245,9 @@ def main():
'Operating System :: Microsoft',
'Operating System :: OS Independent',
'Operating System :: POSIX :: BSD :: FreeBSD',
+ 'Operating System :: POSIX :: BSD :: NetBSD',
'Operating System :: POSIX :: BSD :: OpenBSD',
+ 'Operating System :: POSIX :: BSD',
'Operating System :: POSIX :: Linux',
'Operating System :: POSIX :: SunOS/Solaris',
'Operating System :: POSIX',
@@ -269,6 +271,7 @@ def main():
'Topic :: System :: Monitoring',
'Topic :: System :: Networking :: Monitoring',
'Topic :: System :: Networking',
+ 'Topic :: System :: Operating System',
'Topic :: System :: Systems Administration',
'Topic :: Utilities',
],