summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2019-03-01 03:29:28 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2019-03-01 03:29:28 +0100
commitd8659cfa35a0da589cb0a303f0e856c0f0d1b087 (patch)
treeaa6d02460857918e615cf48cee2ccbc57273dfc4
parent611a12323c73e063d4b33eea363dc073388d4686 (diff)
downloadpsutil-d8659cfa35a0da589cb0a303f0e856c0f0d1b087.tar.gz
add new make command to check tar.gz sanity
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 24ee6db6..592cda44 100644
--- a/Makefile
+++ b/Makefile
@@ -20,6 +20,7 @@ DEPS = \
sphinx \
twine \
unittest2 \
+ virtualenv \
wheel
# In not in a virtualenv, add --user options for install commands.
@@ -206,9 +207,16 @@ upload-win-wheels: ## Upload wheels in dist/* directory on PyPI.
# --- others
+check-src-dist: ## Make sure we can install from the (MANIFEST-based) tar.gz
+ rm -rf dist
+ $(PYTHON) -m virtualenv build/venv
+ PYTHONWARNINGS=all $(PYTHON) setup.py sdist
+ build/venv/bin/python -m pip install dist/*.tar.gz
+ build/venv/bin/python -c "import psutil"
+
pre-release: ## Check if we're ready to produce a new release.
rm -rf dist
- ${MAKE} install
+ ${MAKE} check-src-dist
${MAKE} generate-manifest
git diff MANIFEST.in > /dev/null # ...otherwise 'git diff-index HEAD' will complain
${MAKE} win-download-wheels