summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2016-03-05 21:17:42 +0100
committerGiampaolo Rodola <g.rodola@gmail.com>2016-03-05 21:17:42 +0100
commit663d7a6cc8867b5401027b172be2cfa43627c425 (patch)
tree30647cf64d15c192cf312478215889c80c13542f
parentc3a60b771141e5a6bbed7c9c353183ad0b430eec (diff)
downloadpsutil-663d7a6cc8867b5401027b172be2cfa43627c425.tar.gz
update doc
-rw-r--r--INSTALL.rst44
-rw-r--r--docs/index.rst18
-rw-r--r--psutil/__init__.py2
3 files changed, 32 insertions, 32 deletions
diff --git a/INSTALL.rst b/INSTALL.rst
index 2a98e193..a38980fc 100644
--- a/INSTALL.rst
+++ b/INSTALL.rst
@@ -29,27 +29,30 @@ Since wheels installers are also available you may also use pip.
Compiling on Windows using Visual Studio
========================================
-In order to compile psutil on Windows you'll need Visual Studio (Mingw32 is
-no longer supported). You must have the same version of Visual Studio used to
-compile your installation of Python, that is::
+In order to compile psutil on Windows you'll need **Visual Studio** (**Mingw32
+is no longer supported**). Depending on the Python version you'll also need a
+specific VS version.
+The links reported down here used to work at the time this was written
+(Sep 2015):
-* Python 2.6: VS 2008 (download it from `here <http://www.microsoft.com/en-us/download/details.aspx?id=44266>`_)
-* Python 2.7: VS 2008 (download it from `here <http://www.microsoft.com/en-us/download/details.aspx?id=44266>`_)
-* Python 3.3, 3.4: VS 2010 (you can download it from `MS website <http://www.visualstudio.com/downloads/download-visual-studio-vs#d-2010-express>`_)
-* Python 3.5: `VS 2015 UP <http://www.visualstudio.com/en-au/news/vs2015-preview-vs>`_
+* Python 2.6: VS 2008 (download it from `here <http://www.microsoft.com/en-us/download/details.aspx?id=44266>`__).
+* Python 2.7: VS 2008 (download it from `here <http://www.microsoft.com/en-us/download/details.aspx?id=44266>`__).
+* Python 3.3: VS 2010 (download it from `here <http://www.visualstudio.com/downloads/download-visual-studio-vs#d-2010-express>`__).
+* Python 3.4: VS 2010 (download it from `here <http://www.visualstudio.com/downloads/download-visual-studio-vs#d-2010-express>`__).
+* Python 3.5+: VS 2015 (download it from `here <http://www.visualstudio.com/en-au/news/vs2015-preview-vs>`__).
-...then run::
+To build:
setup.py build
-...or::
+To install:
- make.bat build
+ setup.py install
Compiling 64 bit versions of Python 2.6 and 2.7 with VS 2008 requires
Windows SDK and .NET Framework 3.5 SP1 to be installed first.
-Once you have those run vcvars64.bat, then compile:
-http://stackoverflow.com/questions/11072521/
+Once you have those run vcvars64.bat, then compile (see
+`here <http://stackoverflow.com/questions/11072521/>`__).
===================
Installing on Linux
@@ -74,10 +77,8 @@ Installing on OSX
=================
OSX installation from source will require gcc which you can obtain as part of
-the 'XcodeTools' installer from Apple:
-
-https://developer.apple.com/downloads/?name=Xcode
-
+the `XcodeTools <https://developer.apple.com/downloads/?name=Xcode>`__
+installer from Apple.
Once you have installed XCode you can run the standard distutils commands.
To build only::
@@ -111,9 +112,10 @@ Makefile
A makefile is available for both UNIX and Windows (make.bat). It provides
some automations for the tasks described above and might be preferred over
-using setup.py. With it you can::
+using setup.py. Some useful commands:
- $ make install # just install (in --user mode)
- $ make uninstall # uninstall (needs pip)
- $ make test # run tests
- $ make clean # remove installation files
+ $ make install # just install (in --user mode)
+ $ make uninstall # uninstall (needs pip)
+ $ make setup-dev-env # install all dev deps for running tests, building doc, etc
+ $ make test # run tests
+ $ make clean # remove installation files
diff --git a/docs/index.rst b/docs/index.rst
index e9b09a52..6928d8fc 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -536,16 +536,14 @@ Network
system as a dictionary whose keys are the NIC names and value is a namedtuple
with the following fields:
- - **isup**
- - **duplex**
- - **speed**
- - **mtu**
-
- *isup* is a boolean indicating whether the NIC is up and running, *duplex*
- can be either :const:`NIC_DUPLEX_FULL`, :const:`NIC_DUPLEX_HALF` or
- :const:`NIC_DUPLEX_UNKNOWN`, *speed* is the NIC speed expressed in mega bits
- (MB), if it can't be determined (e.g. 'localhost') it will be set to ``0``,
- *mtu* is the maximum transmission unit expressed in bytes.
+ - **isup**: a bool indicating whether the NIC is up and running.
+ - **duplex**: the duplex communication type;
+ it can be either :const:`NIC_DUPLEX_FULL`, :const:`NIC_DUPLEX_HALF` or
+ :const:`NIC_DUPLEX_UNKNOWN`.
+ - **speed**: the NIC speed expressed in mega bits (MB), if it can't be
+ determined (e.g. 'localhost') it will be set to ``0``.
+ - **mtu**: NIC's maximum transmission unit expressed in bytes.
+
See also `scripts/ifconfig.py <https://github.com/giampaolo/psutil/blob/master/scripts/ifconfig.py>`__
for an example application.
Example:
diff --git a/psutil/__init__.py b/psutil/__init__.py
index 8c8fbae0..a8ab42dc 100644
--- a/psutil/__init__.py
+++ b/psutil/__init__.py
@@ -187,7 +187,7 @@ __all__ = [
]
__all__.extend(_psplatform.__extra__all__)
__author__ = "Giampaolo Rodola'"
-__version__ = "4.0.0"
+__version__ = "4.1.0"
version_info = tuple([int(num) for num in __version__.split('.')])
AF_LINK = _psplatform.AF_LINK
_TOTAL_PHYMEM = None