summaryrefslogtreecommitdiff
path: root/.ci
diff options
context:
space:
mode:
authorGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 12:29:14 +0200
committerGiampaolo Rodola <g.rodola@gmail.com>2017-05-12 12:29:14 +0200
commitb258d829066c21869a8993535798122ab57812e6 (patch)
tree85005576de0af20337a4388f76fdf11b6ed5376f /.ci
parent78742c763893cc2d11ec1c7201c920f8cef74fcf (diff)
downloadpsutil-b258d829066c21869a8993535798122ab57812e6.tar.gz
#1058: enable warnings on make.bat, appveyor and travis
Diffstat (limited to '.ci')
-rwxr-xr-x.ci/travis/run.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/.ci/travis/run.sh b/.ci/travis/run.sh
index a0cdd1b6..05bc60c2 100755
--- a/.ci/travis/run.sh
+++ b/.ci/travis/run.sh
@@ -19,16 +19,16 @@ python setup.py develop
# run tests (with coverage)
if [[ $PYVER == '2.7' ]] && [[ "$(uname -s)" != 'Darwin' ]]; then
- coverage run psutil/tests/__main__.py
+ python -Wa -m coverage run psutil/tests/__main__.py
else
- python psutil/tests/__main__.py
+ python -Wa psutil/tests/__main__.py
fi
if [ "$PYVER" == "2.7" ] || [ "$PYVER" == "3.6" ]; then
# run mem leaks test
- python psutil/tests/test_memory_leaks.py
+ python -Wa psutil/tests/test_memory_leaks.py
# run linter (on Linux only)
if [[ "$(uname -s)" != 'Darwin' ]]; then
- python -m flake8
+ python -Wa -m flake8
fi
fi