summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 11 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 613d8b1..e276878 100644
--- a/setup.py
+++ b/setup.py
@@ -1,15 +1,22 @@
#!/usr/bin/env python
from distutils.core import setup
+import sys
+
+py_modules = ['pies']
+install_requires = []
+if sys.version < '3':
+ install_requires += ['ordereddict', 'argparse']
+ py_modules += ['configparser']
setup(name='pies',
- version='1.0.1',
+ version='1.0.2',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-1.0.0.tar.gz?raw=true',
license="GNU GPLv2",
- install_requires=['ordereddict'],
- requires=['ordereddict'],
- py_modules=['pies'])
+ install_requires=install_requires,
+ requires=install_requires,
+ py_modules=py_modules)