summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2013-11-24 21:27:30 -0500
committerTimothy Crosley <timothy.crosley@gmail.com>2013-11-24 21:27:30 -0500
commit6ab8edafabb2ff47cce842f81ea7f6a29ead8a00 (patch)
treef135bd06b71680535e031e8f7f4085d2d292270e /setup.py
parentf56d486b9480df372cacca85836b754b344079e1 (diff)
parent390f410fb7a5ad1492d24356ff44e90acd9642b1 (diff)
downloadpies-6ab8edafabb2ff47cce842f81ea7f6a29ead8a00.tar.gz
Merge branch 'release/2.0.1'2.0.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 26 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 8d160c2..c537514 100644
--- a/setup.py
+++ b/setup.py
@@ -17,14 +17,37 @@ elif sys.version_info[1] < 2:
if sys.version_info[0] < 3 or sys.version_info[1] < 4:
install_requires += ['enum34']
+try:
+ import pypandoc
+ readme = pypandoc.convert('README.md', 'rst')
+except (IOError, ImportError):
+ readme = ''
+
setup(name='pies',
- version='2.0.0',
+ version='2.0.1',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
+ long_readme=readme,
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-1.0.2.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.0.1.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,
- packages=['pies'])
+ packages=['pies'],
+ keywords='Python, Python2, Python3, six, future, refactoring, single-code-base',
+ classifiers=['Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Natural Language :: English',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.0',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Utilities'])