summaryrefslogtreecommitdiff
path: root/pies2overrides/setup.py
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2015-07-12 00:34:45 -0700
committerTimothy Crosley <timothy.crosley@gmail.com>2015-07-12 00:34:45 -0700
commit173be089008b89c3dfee74420973f98f6e8b0ef3 (patch)
tree4f768358ea29502a217186ccf219b354ed41cf7a /pies2overrides/setup.py
parente3f9fdf008f1c1f803c33ac93cefac0e01f6fdfd (diff)
parentb713d996484fac9d2a4a2e85bee3073a98cabacf (diff)
downloadpies-173be089008b89c3dfee74420973f98f6e8b0ef3.tar.gz
Merge branch 'release/2.6.7'2.6.7master
Diffstat (limited to 'pies2overrides/setup.py')
-rw-r--r--pies2overrides/setup.py14
1 files changed, 5 insertions, 9 deletions
diff --git a/pies2overrides/setup.py b/pies2overrides/setup.py
index 8c4d323..6a96e63 100644
--- a/pies2overrides/setup.py
+++ b/pies2overrides/setup.py
@@ -9,20 +9,16 @@ try:
except ImportError:
from distutils.core import setup
-install_requires = ['ipaddress']
-if sys.version_info[0] == 2 and sys.version_info[1] < 7:
- install_requires += ['ordereddict', 'argparse']
-
setup(name='pies2overrides',
- version='2.6.5',
+ version='2.6.7',
description='Defines override classes that should be included with pies only if running on Python2.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.6.5.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.6.7.tar.gz?raw=true',
license="MIT",
- install_requires=install_requires,
- requires=install_requires,
+ install_requires=['ipaddress'],
+ requires=['ipaddress'],
extras_require={':python_version=="2.6"': ['ordereddict', 'argparse']},
- py_modules=['configparser', 'builtins', '_thread', 'copyreg', 'queue', 'reprlib', 'socketserver'],
+ py_modules=['configparser', 'builtins', 'copyreg', 'queue', 'reprlib', 'socketserver'],
packages=['html', 'http', 'xmlrpc'])