summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2013-09-04 21:02:49 -0400
committerTimothy Crosley <timothy.crosley@gmail.com>2013-09-04 21:02:49 -0400
commitb06c4dfedfe50cf8857ddb9f5de0e4f0885dc517 (patch)
tree688cecddbb0ce48547815c66bf1c01145777e060
parent60a016d68022f1846cb4282e46f84a62f474e51c (diff)
parent4dbec9b1ec9804ff5fb496d82ea55f78aaf8dbd8 (diff)
downloadpies-b06c4dfedfe50cf8857ddb9f5de0e4f0885dc517.tar.gz
Release 1.0.3
-rw-r--r--MANIFEST1
-rw-r--r--dist/pies-1.0.3.tar.gzbin0 -> 1515 bytes
-rw-r--r--pies2overrides/MANIFEST3
-rw-r--r--pies2overrides/configparser.py (renamed from configparser.py)0
-rw-r--r--pies2overrides/dist/pies2overrides-1.0.0.tar.gzbin0 -> 720 bytes
-rw-r--r--pies2overrides/setup.py15
-rw-r--r--setup.py8
7 files changed, 21 insertions, 6 deletions
diff --git a/MANIFEST b/MANIFEST
index 40f3fc8..9551cfd 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -1,4 +1,3 @@
# file GENERATED by distutils, do NOT edit
-configparser.py
pies.py
setup.py
diff --git a/dist/pies-1.0.3.tar.gz b/dist/pies-1.0.3.tar.gz
new file mode 100644
index 0000000..6ac5bd0
--- /dev/null
+++ b/dist/pies-1.0.3.tar.gz
Binary files differ
diff --git a/pies2overrides/MANIFEST b/pies2overrides/MANIFEST
new file mode 100644
index 0000000..7156ab1
--- /dev/null
+++ b/pies2overrides/MANIFEST
@@ -0,0 +1,3 @@
+# file GENERATED by distutils, do NOT edit
+configparser.py
+setup.py
diff --git a/configparser.py b/pies2overrides/configparser.py
index b2da53a..b2da53a 100644
--- a/configparser.py
+++ b/pies2overrides/configparser.py
diff --git a/pies2overrides/dist/pies2overrides-1.0.0.tar.gz b/pies2overrides/dist/pies2overrides-1.0.0.tar.gz
new file mode 100644
index 0000000..a3f449b
--- /dev/null
+++ b/pies2overrides/dist/pies2overrides-1.0.0.tar.gz
Binary files differ
diff --git a/pies2overrides/setup.py b/pies2overrides/setup.py
new file mode 100644
index 0000000..d88ca3c
--- /dev/null
+++ b/pies2overrides/setup.py
@@ -0,0 +1,15 @@
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+setup(name='pies2overrides',
+ version='1.0.0',
+ description='Defines override classes that should be included with pies only if running on Python2.',
+ author='Timothy Crosley',
+ author_email='timothy.crosley@gmail.com',
+ url='https://github.com/timothycrosley/pies',
+ download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-1.0.0.tar.gz?raw=true',
+ license="GNU GPLv2",
+ install_requires=['ordereddict', 'argparse'],
+ requires=['ordereddict', 'argparse'],
+ py_modules=['configparser'])
diff --git a/setup.py b/setup.py
index ce0865f..b36ca02 100644
--- a/setup.py
+++ b/setup.py
@@ -3,14 +3,12 @@
from distutils.core import setup
import sys
-py_modules = ['pies']
install_requires = []
if sys.version < '3':
- install_requires += ['ordereddict', 'argparse']
- py_modules += ['configparser']
+ install_requires += ['pies2overrides']
setup(name='pies',
- version='1.0.2',
+ version='1.0.3',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
@@ -19,4 +17,4 @@ setup(name='pies',
license="GNU GPLv2",
install_requires=install_requires,
requires=install_requires,
- py_modules=py_modules)
+ py_modules=['pies'])