summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2013-11-24 18:56:50 -0500
committerTimothy Crosley <timothy.crosley@gmail.com>2013-11-24 18:56:50 -0500
commitb0493798e746c0798f56b10e1f6380f5cf55f477 (patch)
tree96e437581fd6768711d0880439bec28a1081ddf0
parentf56d486b9480df372cacca85836b754b344079e1 (diff)
downloadpies-b0493798e746c0798f56b10e1f6380f5cf55f477.tar.gz
Add relevent tags, fix version, add long description using pypandoc
-rw-r--r--LICENSE21
-rw-r--r--setup.py27
2 files changed, 46 insertions, 2 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..b5083a5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2013 Timothy Edmund Crosley
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/setup.py b/setup.py
index 8d160c2..cd15bc1 100644
--- a/setup.py
+++ b/setup.py
@@ -17,14 +17,37 @@ elif sys.version_info[1] < 2:
if sys.version_info[0] < 3 or sys.version_info[1] < 4:
install_requires += ['enum34']
+try:
+ import pypandoc
+ readme = pypandoc.convert('README.md', 'rst')
+except (IOError, ImportError):
+ readme = ''
+
setup(name='pies',
version='2.0.0',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
+ long_readme=readme,
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-1.0.2.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.0.0.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,
- packages=['pies'])
+ packages=['pies'],
+ keywords='Python, Python2, Python3, six, future, refactoring, single-code-base',
+ classifiers=['Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Natural Language :: English',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.0',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Utilities'])