summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2013-11-24 21:27:30 -0500
committerTimothy Crosley <timothy.crosley@gmail.com>2013-11-24 21:27:30 -0500
commit6ab8edafabb2ff47cce842f81ea7f6a29ead8a00 (patch)
treef135bd06b71680535e031e8f7f4085d2d292270e
parentf56d486b9480df372cacca85836b754b344079e1 (diff)
parent390f410fb7a5ad1492d24356ff44e90acd9642b1 (diff)
downloadpies-6ab8edafabb2ff47cce842f81ea7f6a29ead8a00.tar.gz
Merge branch 'release/2.0.1'2.0.1
-rw-r--r--LICENSE21
-rw-r--r--pies/overrides.py12
-rw-r--r--pies2overrides/setup.py4
-rw-r--r--setup.py29
4 files changed, 56 insertions, 10 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..b5083a5
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2013 Timothy Edmund Crosley
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/pies/overrides.py b/pies/overrides.py
index 6c6157c..926d51b 100644
--- a/pies/overrides.py
+++ b/pies/overrides.py
@@ -26,7 +26,7 @@ from numbers import Integral
from .version_info import PY2, PY3, VERSION
-__version__ = "2.0.0"
+__version__ = "2.0.1"
native_dict = dict
native_round = round
@@ -95,12 +95,14 @@ else:
range = xrange
integer_types = (int, long)
- for removed in ('apply', 'cmp', 'coerce', 'execfile', 'raw_input', 'unpacks'):
+ def _create_not_allowed(name):
def _not_allow(*args, **kwargs):
- raise NameError("name '{0}' is not defined".format(removed))
+ raise NameError("name '{0}' is not defined".format(name))
+ _not_allow.__name__ = name
+ return _not_allow
- _not_allow.__name__ = removed
- globals()[removed] = _not_allow
+ for removed in ('apply', 'cmp', 'coerce', 'execfile', 'raw_input', 'unpacks'):
+ globals()[removed] = _create_not_allowed(removed)
def u(string):
return codecs.unicode_escape_decode(string[0])
diff --git a/pies2overrides/setup.py b/pies2overrides/setup.py
index d8768ab..45881a0 100644
--- a/pies2overrides/setup.py
+++ b/pies2overrides/setup.py
@@ -14,12 +14,12 @@ if sys.version_info[0] == 2 and sys.version_info[1] < 7:
install_requires += ['ordereddict', 'argparse']
setup(name='pies2overrides',
- version='2.0.0',
+ version='2.0.1',
description='Defines override classes that should be included with pies only if running on Python2.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.0.0.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.0.1.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,
diff --git a/setup.py b/setup.py
index 8d160c2..c537514 100644
--- a/setup.py
+++ b/setup.py
@@ -17,14 +17,37 @@ elif sys.version_info[1] < 2:
if sys.version_info[0] < 3 or sys.version_info[1] < 4:
install_requires += ['enum34']
+try:
+ import pypandoc
+ readme = pypandoc.convert('README.md', 'rst')
+except (IOError, ImportError):
+ readme = ''
+
setup(name='pies',
- version='2.0.0',
+ version='2.0.1',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
+ long_readme=readme,
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-1.0.2.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.0.1.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,
- packages=['pies'])
+ packages=['pies'],
+ keywords='Python, Python2, Python3, six, future, refactoring, single-code-base',
+ classifiers=['Development Status :: 5 - Production/Stable',
+ 'Intended Audience :: Developers',
+ 'Natural Language :: English',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.0',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+ 'Programming Language :: Python :: 3.3',
+ 'Topic :: Software Development :: Libraries',
+ 'Topic :: Utilities'])