summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2013-09-01 20:55:45 -0400
committerTimothy Crosley <timothy.crosley@gmail.com>2013-09-01 20:55:45 -0400
commit3cfb6d7b934284bb8f11ef9278d01ec3bb4b24c9 (patch)
tree0f9c9226b51140624fde0bceb4d5560e92c99e6f
parentcb683a4f01e3f8c886184ecc8a9c2db411227c96 (diff)
downloadpies-3cfb6d7b934284bb8f11ef9278d01ec3bb4b24c9.tar.gz
Imporved readme, import py 2.6+ futures
-rw-r--r--MANIFEST3
-rw-r--r--README.md13
-rw-r--r--build/lib.linux-x86_64-2.7/pies.py81
-rw-r--r--dist/pies-1.0.0.tar.gzbin0 -> 1504 bytes
-rw-r--r--dist/pies-1.0.1.tar.gzbin0 -> 1530 bytes
-rw-r--r--pies.py4
-rw-r--r--setup.py2
7 files changed, 99 insertions, 4 deletions
diff --git a/MANIFEST b/MANIFEST
new file mode 100644
index 0000000..9551cfd
--- /dev/null
+++ b/MANIFEST
@@ -0,0 +1,3 @@
+# file GENERATED by distutils, do NOT edit
+pies.py
+setup.py
diff --git a/README.md b/README.md
index 98ac9c2..5daedd4 100644
--- a/README.md
+++ b/README.md
@@ -4,6 +4,17 @@ pies!
The simplest (and tastiest) way to write one program that runs on both Python 2.6+ and Python 3.
+How does pies differ from six?
+====================
+
+Pies is significantly smaller and simpler then six because it assumes for
+everything possible the developer is using the Python 3 compatible versions included with Python 2.6+,
+whereas six tries to maintain compatibility with Python 2.4 -
+leading to many more overrides and further into different language territory.
+Additionally where possible pies tries to enable you to not have to change syntax at all -
+pass including the import.
+
+
Let's eat some pies!
======================
@@ -41,5 +52,5 @@ The following will work unchanged in Python 3 after import (using the Python 2 s
- urllib.unquote_plus
- urllib.urlencode
-pies will also automatically install and include the most optimal version of OrderedDict for the python environment
+pies will also automatically install and include the most optimal version of OrderedDict for the Python environment
in use, so you should remove any other explicit imports of OrderedDict.
diff --git a/build/lib.linux-x86_64-2.7/pies.py b/build/lib.linux-x86_64-2.7/pies.py
new file mode 100644
index 0000000..99ffe85
--- /dev/null
+++ b/build/lib.linux-x86_64-2.7/pies.py
@@ -0,0 +1,81 @@
+"""
+ pies.py
+
+ Adds necessary hooks to allow Python code to run on multiple major versions of Python at once
+ (currently 2.6 - 3.x)
+
+ Usage:
+ Anywhere you want to gain support for multiple versions of Python simply add the following line
+ from pies import *
+
+ Copyright (C) 2013 Timothy Edmund Crosley
+
+ This program is free software; you can redistribute it and/or
+ modify it under the terms of the GNU General Public License
+ as published by the Free Software Foundation; either version 2
+ of the License, or (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+"""
+
+from __future__ import division, print_function, absolute_import, unicode_literals
+
+import sys
+
+__version__ = "1.0.0"
+
+if sys.version > '3':
+ import urllib
+ from urllib import parse
+
+ from collections import OrderedDict
+
+ long = int
+ unicode = str
+
+ def u(string):
+ return string
+
+ def iteritems(collection):
+ return collection.items()
+
+ def itervalues(collection):
+ return collection.values()
+
+ def iterkeys(collection):
+ return collection.keys()
+
+ def xrange(*args):
+ return range(*args)
+
+ urllib.quote = parse.quote
+ urllib.quote_plus = parse.quote_plus
+ urllib.unquote = parse.unquote
+ urllib.unquote_plus = parse.unquote_plus
+ urllib.urlencode = parse.urlencode
+else:
+ try:
+ from collections import OrderedDict
+ except ImportError:
+ from ordereddict import OrderedDict
+
+ import codecs
+
+ def u(string):
+ return codecs.unicode_escape_decode(string)[0]
+
+ def iteritems(collection):
+ return collection.iteritems()
+
+ def itervalues(collection):
+ return collection.itervalues()
+
+ def iterkeys(collection):
+ return collection.iterkeys()
diff --git a/dist/pies-1.0.0.tar.gz b/dist/pies-1.0.0.tar.gz
new file mode 100644
index 0000000..a947bf1
--- /dev/null
+++ b/dist/pies-1.0.0.tar.gz
Binary files differ
diff --git a/dist/pies-1.0.1.tar.gz b/dist/pies-1.0.1.tar.gz
new file mode 100644
index 0000000..2990963
--- /dev/null
+++ b/dist/pies-1.0.1.tar.gz
Binary files differ
diff --git a/pies.py b/pies.py
index 0e44e40..2fb8e6b 100644
--- a/pies.py
+++ b/pies.py
@@ -25,9 +25,9 @@
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
"""
-import sys
+from __future__ import division, print_function, absolute_import, unicode_literals
-__version__ = "1.0.0"
+import sys
if sys.version > '3':
import urllib
diff --git a/setup.py b/setup.py
index 457477b..613d8b1 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from distutils.core import setup
setup(name='pies',
- version='1.0.0',
+ version='1.0.1',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',