summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Edmund Crosley <timothy.crosley@gmail.com>2013-09-03 19:29:53 -0700
committerTimothy Edmund Crosley <timothy.crosley@gmail.com>2013-09-03 19:29:53 -0700
commit31a06f2bd338e79923ca44055e2e7a82f08859c2 (patch)
treea556fc21577b1fc6cdbd98cdcdbf1cbe928030e9
parent75d1646199385b11ab3a5f4cbb7da6732adb15e5 (diff)
parent13565f151021d1eb14147bf58b7aedc42cd4d875 (diff)
downloadpies-31a06f2bd338e79923ca44055e2e7a82f08859c2.tar.gz
Merge pull request #4 from timothycrosley/feature/include-arg-parser
1.0.2 release, with smarter imports and support for argparser
-rw-r--r--.gitignore1
-rw-r--r--MANIFEST1
-rw-r--r--README.md2
-rw-r--r--build/lib.linux-x86_64-2.7/pies.py81
-rw-r--r--configparser.py1
-rw-r--r--dist/pies-1.0.2.tar.gzbin0 -> 1581 bytes
-rw-r--r--pies.py2
-rw-r--r--setup.py15
8 files changed, 16 insertions, 87 deletions
diff --git a/.gitignore b/.gitignore
index 571fa1a..565093f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
*.pyc
~*
*.swp*
+build
diff --git a/MANIFEST b/MANIFEST
index 9551cfd..40f3fc8 100644
--- a/MANIFEST
+++ b/MANIFEST
@@ -1,3 +1,4 @@
# file GENERATED by distutils, do NOT edit
+configparser.py
pies.py
setup.py
diff --git a/README.md b/README.md
index 5daedd4..57aa794 100644
--- a/README.md
+++ b/README.md
@@ -32,6 +32,8 @@ Integrating pies into your diet
Using and integrating pies into an existing Python 2.6 code base (to achieve Python 3 dual support) couldn't be simpler:
+ from __future__ import absolute_, division, print_function, unicode_literals
+
from pies import *
You will then simply have to make some simple changes to your Python code:
diff --git a/build/lib.linux-x86_64-2.7/pies.py b/build/lib.linux-x86_64-2.7/pies.py
deleted file mode 100644
index 99ffe85..0000000
--- a/build/lib.linux-x86_64-2.7/pies.py
+++ /dev/null
@@ -1,81 +0,0 @@
-"""
- pies.py
-
- Adds necessary hooks to allow Python code to run on multiple major versions of Python at once
- (currently 2.6 - 3.x)
-
- Usage:
- Anywhere you want to gain support for multiple versions of Python simply add the following line
- from pies import *
-
- Copyright (C) 2013 Timothy Edmund Crosley
-
- This program is free software; you can redistribute it and/or
- modify it under the terms of the GNU General Public License
- as published by the Free Software Foundation; either version 2
- of the License, or (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
-"""
-
-from __future__ import division, print_function, absolute_import, unicode_literals
-
-import sys
-
-__version__ = "1.0.0"
-
-if sys.version > '3':
- import urllib
- from urllib import parse
-
- from collections import OrderedDict
-
- long = int
- unicode = str
-
- def u(string):
- return string
-
- def iteritems(collection):
- return collection.items()
-
- def itervalues(collection):
- return collection.values()
-
- def iterkeys(collection):
- return collection.keys()
-
- def xrange(*args):
- return range(*args)
-
- urllib.quote = parse.quote
- urllib.quote_plus = parse.quote_plus
- urllib.unquote = parse.unquote
- urllib.unquote_plus = parse.unquote_plus
- urllib.urlencode = parse.urlencode
-else:
- try:
- from collections import OrderedDict
- except ImportError:
- from ordereddict import OrderedDict
-
- import codecs
-
- def u(string):
- return codecs.unicode_escape_decode(string)[0]
-
- def iteritems(collection):
- return collection.iteritems()
-
- def itervalues(collection):
- return collection.itervalues()
-
- def iterkeys(collection):
- return collection.iterkeys()
diff --git a/configparser.py b/configparser.py
new file mode 100644
index 0000000..b2da53a
--- /dev/null
+++ b/configparser.py
@@ -0,0 +1 @@
+from ConfigParser import *
diff --git a/dist/pies-1.0.2.tar.gz b/dist/pies-1.0.2.tar.gz
new file mode 100644
index 0000000..aea5751
--- /dev/null
+++ b/dist/pies-1.0.2.tar.gz
Binary files differ
diff --git a/pies.py b/pies.py
index 2fb8e6b..a0f8461 100644
--- a/pies.py
+++ b/pies.py
@@ -25,8 +25,6 @@
Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
"""
-from __future__ import division, print_function, absolute_import, unicode_literals
-
import sys
if sys.version > '3':
diff --git a/setup.py b/setup.py
index 613d8b1..e276878 100644
--- a/setup.py
+++ b/setup.py
@@ -1,15 +1,22 @@
#!/usr/bin/env python
from distutils.core import setup
+import sys
+
+py_modules = ['pies']
+install_requires = []
+if sys.version < '3':
+ install_requires += ['ordereddict', 'argparse']
+ py_modules += ['configparser']
setup(name='pies',
- version='1.0.1',
+ version='1.0.2',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-1.0.0.tar.gz?raw=true',
license="GNU GPLv2",
- install_requires=['ordereddict'],
- requires=['ordereddict'],
- py_modules=['pies'])
+ install_requires=install_requires,
+ requires=install_requires,
+ py_modules=py_modules)