summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Crosley <timothy.crosley@gmail.com>2014-01-07 16:56:57 -0500
committerTimothy Crosley <timothy.crosley@gmail.com>2014-01-07 16:56:57 -0500
commite4d26a99feb790b900597a10631ff349da3ec1d2 (patch)
tree063a599e5256a083f55d81bd65e319f4f6cbc413
parent8b784550039dc72eda8a2a8177e39cca4f5add54 (diff)
parenta04f324303586d4edffffcae482891f97e81ba02 (diff)
downloadpies-e4d26a99feb790b900597a10631ff349da3ec1d2.tar.gz
Merge branch 'release/2.5.2'2.5.2
-rw-r--r--pies/__init__.py2
-rw-r--r--pies/ast.py4
-rw-r--r--pies2overrides/setup.py4
-rw-r--r--setup.py4
4 files changed, 7 insertions, 7 deletions
diff --git a/pies/__init__.py b/pies/__init__.py
index af47d20..9bfaae1 100644
--- a/pies/__init__.py
+++ b/pies/__init__.py
@@ -29,4 +29,4 @@
OTHER DEALINGS IN THE SOFTWARE.
"""
-__version__ = "2.5.1"
+__version__ = "2.5.2"
diff --git a/pies/ast.py b/pies/ast.py
index 3821960..015e24e 100644
--- a/pies/ast.py
+++ b/pies/ast.py
@@ -21,8 +21,8 @@ else:
def argument_names(node):
return [arg.arg for arg in node.args.args]
- def kw_only_argument_names(self):
+ def kw_only_argument_names(node):
return [arg.arg for arg in node.args.kwonlyargs]
- def kw_only_default_count(self):
+ def kw_only_default_count(node):
return sum(1 for n in node.args.kw_defaults if n is not None)
diff --git a/pies2overrides/setup.py b/pies2overrides/setup.py
index ba01db5..04ad026 100644
--- a/pies2overrides/setup.py
+++ b/pies2overrides/setup.py
@@ -14,12 +14,12 @@ if sys.version_info[0] == 2 and sys.version_info[1] < 7:
install_requires += ['ordereddict', 'argparse']
setup(name='pies2overrides',
- version='2.5.1',
+ version='2.5.2',
description='Defines override classes that should be included with pies only if running on Python2.',
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.5.1.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/pies2overrides/dist/pies2overrides-2.5.2.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,
diff --git a/setup.py b/setup.py
index 912d2b3..b12fd65 100644
--- a/setup.py
+++ b/setup.py
@@ -24,13 +24,13 @@ except (IOError, ImportError, OSError, RuntimeError):
readme = ''
setup(name='pies',
- version='2.5.1',
+ version='2.5.2',
description='The simplest way to write one program that runs on both Python 2 and Python 3.',
long_description=readme,
author='Timothy Crosley',
author_email='timothy.crosley@gmail.com',
url='https://github.com/timothycrosley/pies',
- download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.5.1.tar.gz?raw=true',
+ download_url='https://github.com/timothycrosley/pies/blob/master/dist/pies-2.5.2.tar.gz?raw=true',
license="MIT",
install_requires=install_requires,
requires=install_requires,