summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Quast <contact@jeffquast.com>2015-01-19 14:55:54 -0800
committerJeff Quast <contact@jeffquast.com>2015-01-19 14:55:54 -0800
commit450f390eaecf88ad95f429ce8b5d03fc8381f158 (patch)
treedd79795a1dcc88a49f486a6b745a702837a82332
parent0565e6c0937c92a3f298832912b0275aaa225217 (diff)
parent35bb9c20ce9ddaa02b26d2ad45e6beee5a49ef73 (diff)
downloadpexpect-450f390eaecf88ad95f429ce8b5d03fc8381f158.tar.gz
Merge pull request #173 from takluyver/update-tooling
Update tooling
-rw-r--r--Makefile81
-rw-r--r--tests/README18
2 files changed, 4 insertions, 95 deletions
diff --git a/Makefile b/Makefile
deleted file mode 100644
index ef9eea2..0000000
--- a/Makefile
+++ /dev/null
@@ -1,81 +0,0 @@
-
-#
-# PEXPECT LICENSE
-#
-# This license is approved by the OSI and FSF as GPL-compatible.
-# http://opensource.org/licenses/isc-license.txt
-#
-# Copyright (c) 2012, Noah Spurrier <noah@noah.org>
-# PERMISSION TO USE, COPY, MODIFY, AND/OR DISTRIBUTE THIS SOFTWARE FOR ANY
-# PURPOSE WITH OR WITHOUT FEE IS HEREBY GRANTED, PROVIDED THAT THE ABOVE
-# COPYRIGHT NOTICE AND THIS PERMISSION NOTICE APPEAR IN ALL COPIES.
-# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
-# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
-# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
-# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
-# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
-# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
-#
-
-SHELL = /bin/sh
-
-VERSION=2.5
-#DOCGENERATOR= happydoc
-DOCGENERATOR=pydoc -w
-# This is for GNU Make. This does not work on BSD Make.
-#MANIFEST_LINES := $(shell cat MANIFEST)
-# This is for BSD Make. This does not work on GNU Make.
-#MANIFEST_LINES != cat MANIFEST
-# I hate Makefiles.
-
-all: merge_templates docs dist
-
-merge_templates:
- python tools/merge_templates.py
-
-docs: doc/index.template.html doc/examples.html doc/clean.css doc/email.png
- make clean_docs
- make merge_templates
- #-rm -f `ls doc/*.html | sed -e 's/doc\/index\.template\.html//' | sed -e 's/doc\/index\.html//'`
- #$(DOCGENERATOR) `echo "$(MANIFEST_LINES)" | sed -e "s/\.py//g" -e "s/setup *//" -e "s/README *//"`
- #mv *.html doc/
- cd doc;\
- $(DOCGENERATOR) ../pexpect.py ../pxssh.py ../fdpexpect.py ../FSM.py ../screen.py ../ANSI.py;\
- cd ..;\
-# tar zcf pexpect-doc-$(VERSION).tar.gz doc/
-
-dist: dist/pexpect-$(VERSION).tar.gz
-
-# $(MANIFEST_LINES)
-
-dist/pexpect-$(VERSION).tar.gz:
- rm -f *.pyc
- rm -f pexpect-$(VERSION).tar.gz
- rm -f dist/pexpect-$(VERSION).tar.gz
- python setup.py sdist
-
-clean: clean_docs
- -rm -f MANIFEST
- -rm -rf __pycache__
- -rm -f *.pyc
- -rm -f tests/*.pyc
- -rm -f tools/*.pyc
- -rm -f dist/*.pyc
- -rm -f *.cover
- -rm -f tests/*.cover
- -rm -f tools/*.cover
- -rm -f dist/pexpect-$(VERSION).tar.gz
- -cd dist;rm -rf pexpect-$(VERSION)/
- -rm -f pexpect-$(VERSION).tar.gz
- -rm -f pexpect-$(VERSION)-examples.tar.gz
- -rm -f pexpect-$(VERSION)-doc.tar.gz
- -rm -f python.core
- -rm -f core
- -rm -f setup.py
- -rm -f doc/index.html
-
-clean_docs:
- -rm -f `ls doc/*.html | sed -e 's/doc\/index\.template\.html//' | sed -e 's/doc\/examples\.html//'`
-
-
diff --git a/tests/README b/tests/README
index 295632b..ef5b613 100644
--- a/tests/README
+++ b/tests/README
@@ -1,18 +1,8 @@
-The best way to run these tests is from the directory above this one. Source
-the test.env environment file. This will make sure that you are using the
-correct pexpect.py file otherwise Python might try to import a different
-version if it is already installed in this environment. Then run the testall.py
-script in the tools/ directory. This script will automatically build a test
-suite from all the test scripts in the tests/ directory. This allows you to add
-new test scripts simply by dropping them in the tests/ directory. You don't
-have to register the test or do anything else to integrate it into the test
-suite.
+The best way to run these tests is from the directory above this one. Run:
-For example, this is the normal set of commands you would use to run all tests
-in the tests/ directory:
+ py.test
- $ cd /home/user/pexpect_dev/
- $ . test.env
- $ ./tools/testall.py
+To run a specific test file:
+ py.test tests/test_constructor.py