summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini17
1 files changed, 9 insertions, 8 deletions
diff --git a/tox.ini b/tox.ini
index fc42fc1..f4356a5 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,19 +5,20 @@
[tox]
envlist = py27, py34, py35, py36, py37, py38, pypy, pypy3, jython
-skipsdist = True
skip_missing_interpreters = True
[testenv]
+deps = coverage
commands =
- {envpython} setup.py install
- {envpython} pycodestyle.py --max-doc-length=72 --testsuite testsuite
- {envpython} pycodestyle.py --statistics pycodestyle.py
- {envpython} pycodestyle.py --max-doc-length=72 --doctest
- {envpython} setup.py test
+ python -m pycodestyle --statistics pycodestyle.py
+ coverage run -m pycodestyle --max-doc-length=72 --testsuite testsuite
+ coverage run -m pycodestyle --max-doc-length=72 --doctest
+ coverage run -m unittest discover testsuite -vv
+ coverage combine
+ coverage report
[testenv:flake8]
-deps =
- flake8
+skip_install = true
+deps = flake8
commands =
flake8 pycodestyle.py