summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 1 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 3f0c363..fe96737 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,3 @@
-# -*- coding: utf-8 -*-
from setuptools import setup
@@ -30,14 +29,9 @@ setup(
url='https://pycodestyle.pycqa.org/',
license='Expat license',
py_modules=['pycodestyle'],
- namespace_packages=[],
include_package_data=True,
zip_safe=False,
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
- install_requires=[
- # Broken with Python 3: https://github.com/pypa/pip/issues/650
- # 'setuptools',
- ],
+ python_requires='>=3.6',
entry_points={
'console_scripts': [
'pycodestyle = pycodestyle:_main',
@@ -50,10 +44,7 @@ setup(
'License :: OSI Approved :: MIT License',
'Operating System :: OS Independent',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',