summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--docs/source/databases.rst4
-rw-r--r--tox.ini26
2 files changed, 27 insertions, 3 deletions
diff --git a/docs/source/databases.rst b/docs/source/databases.rst
index d4d23dc..4eb5a9b 100644
--- a/docs/source/databases.rst
+++ b/docs/source/databases.rst
@@ -37,8 +37,8 @@ By default, this module contains a special method, :func:`init_model`.
"""
This is a stub method which is called at application startup time.
- If you need to bind to a parse database configuration, set up tables or
- ORM classes, or perform any database initialization, this is the
+ If you need to bind to a parsed database configuration, set up tables
+ or ORM classes, or perform any database initialization, this is the
recommended place to do it.
For more information working with databases, and some common recipes,
diff --git a/tox.ini b/tox.ini
index cbd59ab..42a4cb3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -141,7 +141,7 @@ commands = nosetests -v tests/pecantest
[testenv:ceilometer-stable]
basepython = python2.6
-deps = -egit+http://git.openstack.org/cgit/openstack/ceilometer@stable/havana#egg=ceilometer
+deps = -egit+http://git.openstack.org/cgit/openstack/ceilometer@stable/icehouse#egg=ceilometer
changedir = {envdir}/src/ceilometer
commands = tox -e py26 --notest # ensure a virtualenv is built
{envdir}/src/ceilometer/.tox/py26/bin/pip install -U {toxinidir} # install pecan-dev
@@ -155,6 +155,14 @@ commands = tox -e py26 --notest # ensure a virtualenv is built
{envdir}/src/ceilometer/.tox/py26/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py26
+[testenv:ironic-stable]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack/ironic@stable/icehouse#egg=ironic
+changedir = {envdir}/src/ironic
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/ironic/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
[testenv:ironic-tip]
basepython = python2.7
deps = -egit+http://git.openstack.org/cgit/openstack/ironic#egg=ironic
@@ -163,6 +171,22 @@ commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/ironic/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py27
+[testenv:barbican-tip]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack/barbican#egg=barbican
+changedir = {envdir}/src/barbican
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/barbican/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
+[testenv:storyboard-tip]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack-infra/storyboard#egg=storyboard
+changedir = {envdir}/src/storyboard
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/storyboard/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
[testenv:pep8]
deps = pep8
commands = pep8 --repeat --show-source pecan setup.py