summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2014-06-19 13:05:19 -0400
committerRyan Petrello <lists@ryanpetrello.com>2014-06-25 13:23:37 -0400
commitf58d982387181929da1057365f391743255c1014 (patch)
treefdc2e10f7f41f01d02a7c5394426965f2935adf3
parent0973690047cab04d79839eed0abfd383b62b4cf5 (diff)
downloadpecan-f58d982387181929da1057365f391743255c1014.tar.gz
Gate on designate stable and HEAD.
Change-Id: I653c2c7929442eaa3ac4f0950ff68d328e724e5d
-rw-r--r--tox.ini16
1 files changed, 16 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index 42a4cb3..201f1ae 100644
--- a/tox.ini
+++ b/tox.ini
@@ -187,6 +187,22 @@ commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/storyboard/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py27
+[testenv:designate-stable]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack/designate@stable/icehouse#egg=designate
+changedir = {envdir}/src/designate
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/designate/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
+[testenv:designate-tip]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack/designate#egg=designate
+changedir = {envdir}/src/designate
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/designate/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
[testenv:pep8]
deps = pep8
commands = pep8 --repeat --show-source pecan setup.py