summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJenkins <jenkins@review.openstack.org>2014-09-22 23:51:42 +0000
committerGerrit Code Review <review@openstack.org>2014-09-22 23:51:42 +0000
commitd4c230a2c5f9074bec40df372db18e38529c3dd2 (patch)
tree6e4f80dd0b5d061915a4fd55e8ff58c949eb26cb
parent1a546f0240ada065b56029d33f76c83b9fdc801a (diff)
parentf20f6bd2da1c7828e4154fa2b4f58fba8bee5270 (diff)
downloadpecan-d4c230a2c5f9074bec40df372db18e38529c3dd2.tar.gz
Merge "Revert "Import run_cross_tests.sh from oslo-incubator""
-rw-r--r--openstack-common.conf7
-rwxr-xr-xtools/run_cross_tests.sh70
2 files changed, 0 insertions, 77 deletions
diff --git a/openstack-common.conf b/openstack-common.conf
deleted file mode 100644
index 3fffac5..0000000
--- a/openstack-common.conf
+++ /dev/null
@@ -1,7 +0,0 @@
-[DEFAULT]
-
-# The list of modules to copy from oslo-incubator.git
-script = tools/run_cross_tests.sh
-
-# The base module to hold the copy of openstack.common
-base=oslotest
diff --git a/tools/run_cross_tests.sh b/tools/run_cross_tests.sh
deleted file mode 100755
index fb21e65..0000000
--- a/tools/run_cross_tests.sh
+++ /dev/null
@@ -1,70 +0,0 @@
-#!/bin/bash
-#
-# Run cross-project tests
-
-# Fail the build if any command fails
-set -e
-
-project_dir="$1"
-venv="$2"
-
-# Set up the virtualenv without running the tests
-(cd $project_dir && tox --notest -e $venv)
-
-tox_envbin=$project_dir/.tox/$venv/bin
-
-our_name=$(python setup.py --name)
-
-# Replace the pip-installed package with the version in our source
-# tree. Look to see if we are already installed before trying to
-# uninstall ourselves, to avoid failures from packages that do not use us
-# yet.
-if $tox_envbin/pip freeze | grep -q $our_name
-then
- $tox_envbin/pip uninstall -y $our_name
-fi
-$tox_envbin/pip install -U .
-
-# Run the tests
-(cd $project_dir && tox -e $venv)
-result=$?
-
-
-# The below checks are modified from
-# openstack-infra/config/modules/jenkins/files/slave_scripts/run-unittests.sh.
-
-# They expect to be run in the project being tested.
-cd $project_dir
-
-echo "Begin pip freeze output from test virtualenv:"
-echo "======================================================================"
-.tox/$venv/bin/pip freeze
-echo "======================================================================"
-
-# We only want to run the next check if the tool is installed, so look
-# for it before continuing.
-if [ -f /usr/local/jenkins/slave_scripts/subunit2html.py -a -d ".testrepository" ] ; then
- if [ -f ".testrepository/0.2" ] ; then
- cp .testrepository/0.2 ./subunit_log.txt
- elif [ -f ".testrepository/0" ] ; then
- .tox/$venv/bin/subunit-1to2 < .testrepository/0 > ./subunit_log.txt
- fi
- .tox/$venv/bin/python /usr/local/jenkins/slave_scripts/subunit2html.py ./subunit_log.txt testr_results.html
- gzip -9 ./subunit_log.txt
- gzip -9 ./testr_results.html
-
- export PYTHON=.tox/$venv/bin/python
- set -e
- rancount=$(.tox/$venv/bin/testr last | sed -ne 's/Ran \([0-9]\+\).*tests in.*/\1/p')
- if [ "$rancount" -eq "0" ] ; then
- echo
- echo "Zero tests were run. At least one test should have been run."
- echo "Failing this test as a result"
- echo
- exit 1
- fi
-fi
-
-# If we make it this far, report status based on the tests that were
-# run.
-exit $result