summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2014-08-28 12:48:37 -0400
committerRyan Petrello <lists@ryanpetrello.com>2014-08-28 12:48:37 -0400
commit422d0638576bfcbf812bfa96c1f87f1099b2e8ab (patch)
tree27768f677df8e953297ec19a91fbb04456dd2fe7
parentd9f8229c0ee3464fb7414a75cbbfe27cf1aed1b8 (diff)
downloadpecan-422d0638576bfcbf812bfa96c1f87f1099b2e8ab.tar.gz
Version increment.0.7.0
Change-Id: Icd58638f87108a0954dd26db31a22772b4d450ed
-rw-r--r--docs/source/changes.rst13
-rw-r--r--setup.py2
2 files changed, 14 insertions, 1 deletions
diff --git a/docs/source/changes.rst b/docs/source/changes.rst
index 9450e43..0fa3db9 100644
--- a/docs/source/changes.rst
+++ b/docs/source/changes.rst
@@ -1,3 +1,16 @@
+0.7.0
+=====
+* Fixed an edge case in RestController routing which should have returned an
+ HTTP 400 but was instead raising an exception (and thus, HTTP 500).
+* Fixed an incorrect root logger configuration for quickstarted pecan projects.
+* Added `pecan.state.arguments`, a new feature for inspecting controller call
+ arguments.
+* Fixed an infinite recursion error in PecanHook application. Subclassing both
+ `rest.RestController` and `hooks.HookController` resulted in an infinite
+ recursion error in hook application (which prevented applications from
+ starting).
+* Pecan's tests are now included in its source distribution.
+
0.6.1
=====
* Fixed a bug which causes pecan to mistakenly return HTTP 204 for non-empty
diff --git a/setup.py b/setup.py
index c010b76..a0234ac 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@ import platform
from setuptools import setup, find_packages
-version = '0.6.1'
+version = '0.7.0'
#
# determine requirements