summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJenkins <jenkins@review.openstack.org>2014-06-27 14:16:49 +0000
committerGerrit Code Review <review@openstack.org>2014-06-27 14:16:49 +0000
commit2260909302e5fc5633100887b372677e8dab3ebc (patch)
treece82d0489e7d984a65898975729a854293c324a1
parent896fc63701dfd373ded67daf6462d9e34594dbfb (diff)
parentf58d982387181929da1057365f391743255c1014 (diff)
downloadpecan-2260909302e5fc5633100887b372677e8dab3ebc.tar.gz
Merge "Gate on designate stable and HEAD."0.6.0
-rw-r--r--tox.ini16
1 files changed, 16 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index 47ecba2..42b8178 100644
--- a/tox.ini
+++ b/tox.ini
@@ -187,6 +187,22 @@ commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/storyboard/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py27
+[testenv:designate-stable]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack/designate@stable/icehouse#egg=designate
+changedir = {envdir}/src/designate
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/designate/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
+[testenv:designate-tip]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack/designate#egg=designate
+changedir = {envdir}/src/designate
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/designate/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
[testenv:pep8]
deps = pep8
commands = pep8 --repeat --show-source pecan setup.py