summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Petrello <lists@ryanpetrello.com>2014-05-19 16:17:59 -0400
committerRyan Petrello <lists@ryanpetrello.com>2014-05-19 16:17:59 -0400
commit18275cf3e1984d034de8c1aa6dfbc7b9f9771b01 (patch)
treec7a38588111babe65ae28f37914f5236b4bdd22e
parentedeff73f438517d862a47b30a6a0f87e0cdd033e (diff)
downloadpecan-18275cf3e1984d034de8c1aa6dfbc7b9f9771b01.tar.gz
Gate on stable/icehouse, and a few new projects that use pecan.
Change-Id: Ib31ecdb4e23054141511725b90dc10f6a7ec2afe
-rw-r--r--tox.ini26
1 files changed, 25 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index cbd59ab..0c69b9a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -141,7 +141,7 @@ commands = nosetests -v tests/pecantest
[testenv:ceilometer-stable]
basepython = python2.6
-deps = -egit+http://git.openstack.org/cgit/openstack/ceilometer@stable/havana#egg=ceilometer
+deps = -egit+http://git.openstack.org/cgit/openstack/ceilometer@stable/icehouse#egg=ceilometer
changedir = {envdir}/src/ceilometer
commands = tox -e py26 --notest # ensure a virtualenv is built
{envdir}/src/ceilometer/.tox/py26/bin/pip install -U {toxinidir} # install pecan-dev
@@ -155,6 +155,14 @@ commands = tox -e py26 --notest # ensure a virtualenv is built
{envdir}/src/ceilometer/.tox/py26/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py26
+[testenv:ironic-stable]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack/ironic@stable/icehouse#egg=ironic
+changedir = {envdir}/src/ironic
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/ironic/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
[testenv:ironic-tip]
basepython = python2.7
deps = -egit+http://git.openstack.org/cgit/openstack/ironic#egg=ironic
@@ -163,6 +171,22 @@ commands = tox -e py27 --notest # ensure a virtualenv is built
{envdir}/src/ironic/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
tox -e py27
+[testenv:barbican-tip]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/stackforge/barbican#egg=barbican
+changedir = {envdir}/src/barbican
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/barbican/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
+[testenv:storyboard-tip]
+basepython = python2.7
+deps = -egit+http://git.openstack.org/cgit/openstack-infra/storyboard#egg=storyboard
+changedir = {envdir}/src/storyboard
+commands = tox -e py27 --notest # ensure a virtualenv is built
+ {envdir}/src/storyboard/.tox/py27/bin/pip install -U {toxinidir} # install pecan-dev
+ tox -e py27
+
[testenv:pep8]
deps = pep8
commands = pep8 --repeat --show-source pecan setup.py