summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Gr?nholm <alex.gronholm@nextday.fi>2011-05-17 02:57:21 +0300
committerAlex Gr?nholm <alex.gronholm@nextday.fi>2011-05-17 02:57:21 +0300
commite14c20b484f03b3b098b41f1dc8a2f804918b8a9 (patch)
tree97de6215dc56c6a64b17e59d9a73378e4a151529
parent79271738c1f8bfc15fe3a7b1ee6aee84f0aa66e7 (diff)
downloadpastedeploy-e14c20b484f03b3b098b41f1dc8a2f804918b8a9.tar.gz
Added myself as maintainer, cleaned up setup.py and excluded the HTML documentation from the sdist and included template files missing from the previous release(s)
-rw-r--r--MANIFEST.in3
-rw-r--r--docs/news.txt1
-rw-r--r--setup.py18
3 files changed, 8 insertions, 14 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index e5deda2..7a2ffb9 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,3 +1,2 @@
-include docs/*.html
include docs/*.txt
-exclude docs/rebuild
+recursive-include paste/deploy/paster_templates *
diff --git a/docs/news.txt b/docs/news.txt
index a48214a..2655b32 100644
--- a/docs/news.txt
+++ b/docs/news.txt
@@ -5,6 +5,7 @@ hg tip
------
* Was printing extraneous data when calling setup.py
+* Fixed missing paster template files (fixes "paster create -t paste.deploy")
1.3.4
-----
diff --git a/setup.py b/setup.py
index 1959175..583ec97 100644
--- a/setup.py
+++ b/setup.py
@@ -1,16 +1,9 @@
from setuptools import setup, find_packages
-version = '1.3.4'
-
-import os
-
-here = os.path.dirname(os.path.abspath(__file__))
-finddata_py = os.path.join(here, 'tests', 'finddata.py')
-execfile(finddata_py)
setup(
name="PasteDeploy",
- version=version,
+ version='1.5.0dev',
description="Load, configure, and compose WSGI applications and servers",
long_description="""\
This tool provides code to load WSGI applications and servers from
@@ -40,12 +33,13 @@ For the latest changes see the `news file
keywords='web wsgi application server',
author="Ian Bicking",
author_email="ianb@colorstudy.com",
+ maintainer="Alex Gronholm",
+ maintainer_email="alex.gronholm@nextday.fi",
url="http://pythonpaste.org/deploy/",
license='MIT',
namespace_packages=['paste'],
- packages=find_packages(exclude='tests'),
- package_data=find_package_data(
- exclude_directories=standard_exclude_directories + ('tests',)),
+ packages=find_packages(exclude=['tests']),
+ include_package_data=True,
zip_safe=False,
test_suite='nose.collector',
tests_require=['nose>=0.11'],
@@ -70,4 +64,4 @@ For the latest changes see the `news file
paste.server_factory = paste.deploy.epdesc:ServerFactoryDescription
paste.server_runner = paste.deploy.epdesc:ServerRunnerDescription
""",
- )
+)