summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2011-12-01 11:22:46 -0500
committerEli Collins <elic@assurancetechnologies.com>2011-12-01 11:22:46 -0500
commit66cb7c4383aecd0edfc8415d32b3e791717e3c40 (patch)
tree8dbd920a2cf9183fc828fd4fdf3fbfe85017e388 /setup.py
parenta63da91e341a90446340998df7f2e6c7fa71b0b3 (diff)
downloadpasslib-66cb7c4383aecd0edfc8415d32b3e791717e3c40.tar.gz
added Python::Implementation trove classifiers
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 9da2e34..36b55e8 100644
--- a/setup.py
+++ b/setup.py
@@ -130,10 +130,15 @@ Programming Language :: Python :: 2.5
Programming Language :: Python :: 2.6
Programming Language :: Python :: 2.7
Programming Language :: Python :: 3
+Programming Language :: Python :: Implementation :: CPython
+Programming Language :: Python :: Implementation :: Jython
+Programming Language :: Python :: Implementation :: PyPy
Topic :: Security :: Cryptography
Topic :: Software Development :: Libraries
""".splitlines()
+# TODO: also test releases under ironpython -- "Programming Language :: Python :: Implementation :: IronPython"
+
is_release = False
if '.dev' in VERSION:
CLASSIFIERS.append("Development Status :: 3 - Alpha")