summaryrefslogtreecommitdiff
path: root/docs
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2011-08-19 14:37:15 -0400
committerEli Collins <elic@assurancetechnologies.com>2011-08-19 14:37:15 -0400
commit00df5078b8760575321b91fdc878d0c9a04d6c12 (patch)
treee51299b7ace1176bc981ea40cffc78d10b119dab /docs
parent257bf008f87fffa1aaf9e575a4e7e81ca6751e60 (diff)
downloadpasslib-00df5078b8760575321b91fdc878d0c9a04d6c12.tar.gz
small corrections to documentation
Diffstat (limited to 'docs')
-rw-r--r--docs/install.rst11
-rw-r--r--docs/lib/passlib.hash.fshp.rst2
-rw-r--r--docs/lib/passlib.hash.rst7
-rw-r--r--docs/modular_crypt_format.rst28
4 files changed, 29 insertions, 19 deletions
diff --git a/docs/install.rst b/docs/install.rst
index 57e39ab..b524725 100644
--- a/docs/install.rst
+++ b/docs/install.rst
@@ -7,14 +7,15 @@ Supported Platforms
Passlib requires Python 2 (>= 2.5) or Python 3.
It is known to work with the following Python implementations:
-* CPython 2 -- 2.5 or newer.
+* CPython 2 -- v2.5 or newer.
* CPython 3 -- all versions.
-* PyPy -- 1.5 or newer.
-* Jython -- 2.5 or newer.
+* PyPy -- v1.5 or newer.
+* Jython -- v2.5 or newer.
-Passlib should work with all operating systems,
+Passlib should work with all operating systems and enviroments,
as it contains builtin fallbacks
for almost all OS-dependant features.
+Google App Engine is supported as well.
.. _optional-libraries:
@@ -95,4 +96,4 @@ you will need to:
5. Once Sphinx completes it's run, point a web browser to the file at :samp:`{$SOURCE}/build/sphinx/html/index.html`
to access the PassLib documentation in html format.
6. Alternately, steps 4 & 5 can be replaced by running :samp:`python setup.py docdist`,
- which will build a zip file of the documentation in :samp:`{$SOURCE}/dist`. \ No newline at end of file
+ which will build a zip file of the documentation in :samp:`{$SOURCE}/dist`.
diff --git a/docs/lib/passlib.hash.fshp.rst b/docs/lib/passlib.hash.fshp.rst
index ce596da..407d7ac 100644
--- a/docs/lib/passlib.hash.fshp.rst
+++ b/docs/lib/passlib.hash.fshp.rst
@@ -11,7 +11,7 @@ is a cross-platform hash based on PBKDF1 [#pbk]_, and uses an LDAP-style hash fo
It features a variable length salt, variable rounds, and support for cryptographic
hashes from SHA-1 up to SHA-512.
-.. note::
+.. warning::
While the SHA-2 variants of PBKDF1 have no critical security vulnerabilities,
PBKDF1 itself has been deprecated in favor of it's successor, PBKDF2.
diff --git a/docs/lib/passlib.hash.rst b/docs/lib/passlib.hash.rst
index f7be75e..7c58cfe 100644
--- a/docs/lib/passlib.hash.rst
+++ b/docs/lib/passlib.hash.rst
@@ -29,8 +29,11 @@ as in the following example::
.. seealso::
- the :ref:`password-hash-api` details the
- interface used by all password hashes in this module.
+ * :ref:`password-hash-api` -- details the
+ interface used by all password hashes in this module.
+
+ * :doc:`Quickstart Guide </new_app_quickstart>` --
+ for advice on choosing an appropriately secure hash for your new application.
.. _mcf-hashes:
diff --git a/docs/modular_crypt_format.rst b/docs/modular_crypt_format.rst
index 38a46d8..5db4905 100644
--- a/docs/modular_crypt_format.rst
+++ b/docs/modular_crypt_format.rst
@@ -122,8 +122,10 @@ by the modular crypt format hashes found in passlib:
Identifiers & Platform Support
==============================
-The following table lists of all the major MCF hashes supported by passlib,
-and indicates which operating systems offer native support.
+The following table lists of all the major MCF hashes supported by Passlib,
+and indicates which operating systems [#gae]_ offer native support.
+
+.. todo:: include MacOS X in this list
==================================== ==================== =========== =========== =========== =========== =======
Scheme Prefix Linux FreeBSD NetBSD OpenBSD Solaris
@@ -139,24 +141,28 @@ Scheme Prefix Linux FreeBSD
:class:`~passlib.hash.sha1_crypt` ``$sha1$`` y
==================================== ==================== =========== =========== =========== =========== =======
-The following table lists the other MCF hashes supported by passlib,
+The following table lists the other MCF hashes supported by Passlib,
most of which are only used by applications:
=========================================== =================== ===========================
-Scheme Prefix Known Uses
+Scheme Prefix Primary Use (if known)
=========================================== =================== ===========================
:class:`~passlib.hash.apr_md5_crypt` ``$apr1$`` Apache htdigest files
:class:`~passlib.hash.phpass` ``$P$``, ``$H$`` PHPass-based applications
:class:`~passlib.hash.pbkdf2_sha1` ``$pbkdf2$``
:class:`~passlib.hash.pbkdf2_sha256` ``$pbkdf2-sha256$``
:class:`~passlib.hash.pbkdf2_sha512` ``$pbkdf2-sha512$``
-:class:`~passlib.hash.cta_pbkdf2_sha1` ``$p5k2$``
-:class:`~passlib.hash.dlitz_pbkdf2_sha1` ``$p5k2$``
+:class:`~passlib.hash.cta_pbkdf2_sha1` ``$p5k2$`` [#cta]_
+:class:`~passlib.hash.dlitz_pbkdf2_sha1` ``$p5k2$`` [#cta]_
=========================================== =================== ===========================
-.. note::
- :class:`!cta_pbkdf2_sha1` and :class:`!dlitz_pbkdf2_sha1` both use
- the same identifier. They can be distinguished
- by the fact that cta hashes will always end in ``=``, while dlitz
- hashes contain no ``=`` at all.
+.. rubric:: Footnotes
+
+.. [#gae] As of 2011-08-19, Google App Engine's :mod:`crypt` implementation
+ appears to provide hash support matching that of a typical Linux system.
+
+.. [#cta] :class:`!cta_pbkdf2_sha1` and :class:`!dlitz_pbkdf2_sha1` both use
+ the same identifier. They can be distinguished
+ by the fact that cta hashes will always end in ``=``, while dlitz
+ hashes contain no ``=`` at all.