summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Collins <elic@assurancetechnologies.com>2012-05-01 13:06:40 -0400
committerEli Collins <elic@assurancetechnologies.com>2012-05-01 13:06:40 -0400
commit5528b806944f86e28bb6a6d3c87fed56a92eddb2 (patch)
treed8edc6f385ee01b6a8df2b801bf7078e4de52e40
parente0eb8d86b0f7b119656f6e7939a50d436a8f98d8 (diff)
downloadpasslib-5528b806944f86e28bb6a6d3c87fed56a92eddb2.tar.gz
final tweaks to test config files
-rw-r--r--setup.cfg6
-rw-r--r--setup.py4
-rw-r--r--tox.ini44
3 files changed, 28 insertions, 26 deletions
diff --git a/setup.cfg b/setup.cfg
index 1a0031f..42c3766 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -3,9 +3,3 @@ sign = true
[upload_docs]
upload_dir = build/sphinx/html
-
-[test]
-test_suite = nose.collector
-
-[nosetests]
-tests = passlib/tests
diff --git a/setup.py b/setup.py
index 1d2c17a..44dea01 100644
--- a/setup.py
+++ b/setup.py
@@ -119,7 +119,7 @@ Topic :: Security :: Cryptography
Topic :: Software Development :: Libraries
""".splitlines()
-# TODO: also test releases under ironpython -- "Programming Language :: Python :: Implementation :: IronPython"
+# TODO: "Programming Language :: Python :: Implementation :: IronPython" -- issue 34
is_release = False
if '.dev' in VERSION:
@@ -166,7 +166,7 @@ setup(
keywords = KEYWORDS,
classifiers = CLASSIFIERS,
- tests_require = 'nose >= 1.0',
+ tests_require = 'nose >= 1.1',
test_suite = 'nose.collector',
#extra opts
diff --git a/tox.ini b/tox.ini
index e057f47..7ec8464 100644
--- a/tox.ini
+++ b/tox.ini
@@ -37,22 +37,22 @@
#===========================================================================
[tox]
minversion=1.0
-envlist = py27,py32,py25,py26,py31,pypy15,pypy18,jython,gae25,gae27
+envlist = py27,py32,py25,py26,py31,pypy15,pypy16,pypy17,pypy18,jython,gae25,gae27
#===========================================================================
# stock CPython VMs
#===========================================================================
[testenv]
setenv =
- PASSLIB_TEST_MODE = full
- PASSLIB_TEST_FUZZ_TIME = 10
+ PASSLIB_TEST_MODE = full
+ PASSLIB_TEST_FUZZ_TIME = 10
changedir = {envdir}
commands =
- nosetests {posargs:passlib.tests}
+ nosetests {posargs:passlib.tests}
deps =
- nose
+ nose
coverage
- unittest2
+ unittest2
[testenv:py25]
deps =
@@ -63,11 +63,11 @@ deps =
[testenv:py27]
deps =
- nose
+ nose
coverage
- unittest2
- py-bcrypt
- bcryptor
+ unittest2
+ py-bcrypt
+ bcryptor
django
M2Crypto
@@ -88,6 +88,12 @@ deps =
[testenv:pypy15]
basepython = pypy1.5
+[testenv:pypy16]
+basepython = pypy1.6
+
+[testenv:pypy17]
+basepython = pypy1.7
+
[testenv:pypy18]
basepython = pypy1.8
@@ -102,15 +108,15 @@ basepython = pypy1.8
basepython = python2.5
deps =
# FIXME: getting all kinds of errors when using nosegae 0.2.0 :(
- nose
- nosegae==0.1.9
- unittest2
+ nose
+ nosegae==0.1.9
+ unittest2
changedir = {envdir}/lib/python2.5/site-packages
commands =
# setup custom app.yaml so GAE can run
python -m passlib.tests.tox_support setup_gae . python
- # FIXME: have to run using --without-sandbox for now,
+ # FIXME: have to run using --without-sandbox for now,
# something in nose+GAE+virtualenv won't play nice with eachother.
nosetests --with-gae --without-sandbox {posargs:passlib/tests}
@@ -118,15 +124,17 @@ commands =
basepython = python2.7
deps =
# FIXME: getting all kinds of errors when using nosegae 0.2.0 :(
- nose
- nosegae==0.1.9
- unittest2
+ nose
+ nosegae==0.1.9
+ unittest2
changedir = {envdir}/lib/python2.7/site-packages
commands =
# setup custom app.yaml so GAE can run
python -m passlib.tests.tox_support setup_gae . python27
- # FIXME: have to run using --without-sandbox for now,
+ # TODO: figure out how to select django 1.2 so the extension under gae.
+
+ # FIXME: have to run using --without-sandbox for now,
# something in nose+GAE+virtualenv won't play nice with eachother.
nosetests --with-gae --without-sandbox {posargs:passlib/tests}