summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorChangBo Guo(gcb) <eric.guo@easystack.cn>2016-02-29 12:26:43 +0800
committerChangBo Guo(gcb) <eric.guo@easystack.cn>2016-03-03 11:30:00 +0800
commitf776ba27571ae3475e25a347042cb69bed45ceb8 (patch)
tree0d293b977d9c1101b576ab2462f03c8deee31e23 /tox.ini
parent54d58a77583468b51e6843cd1b3d6ef730da44f4 (diff)
downloadosprofiler-f776ba27571ae3475e25a347042cb69bed45ceb8.tar.gz
Enable bandit in gate
Bandit is a tool designed to find common security issues in Python code. and pep8 is the usual linter target. So enable it in pep8 target. Change-Id: Ie5e4350cde906c206fd5041e88983678eb37999e
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini8
1 files changed, 7 insertions, 1 deletions
diff --git a/tox.ini b/tox.ini
index 12e18de..204b9a4 100644
--- a/tox.ini
+++ b/tox.ini
@@ -17,7 +17,10 @@ commands = python setup.py testr --slowest --testr-args='{posargs}'
distribute = false
[testenv:pep8]
-commands = flake8
+commands =
+ flake8
+ # Run security linter
+ bandit -r osprofiler -n5
distribute = false
[testenv:venv]
@@ -30,6 +33,9 @@ commands = python setup.py testr --coverage --testr-args='{posargs}'
changedir = doc/source
commands = make html
+[testenv:bandit]
+commands = bandit -r osprofiler -n5
+
[flake8]
show-source = true
builtins = _