summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorBoris Pavlovic <boris@pavlovic.me>2013-12-24 22:40:37 +0400
committerBoris Pavlovic <boris@pavlovic.me>2014-01-09 11:25:23 +0400
commit903ca86952eeed5fefc166f6b5c14be2f0a8a378 (patch)
treeb5585c3e33b89d769edeb238fdda6687f588bed4 /tox.ini
parent5c3a309c49ad255b3abd391af5cceae28ac92baf (diff)
downloadosprofiler-903ca86952eeed5fefc166f6b5c14be2f0a8a378.tar.gz
Init Strucutre of lib
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini35
1 files changed, 35 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..1314636
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,35 @@
+[tox]
+minversion = 1.6
+skipsdist = True
+envlist = py26,py27,pep8
+
+[testenv]
+setenv = VIRTUAL_ENV={envdir}
+ LANG=en_US.UTF-8
+ LANGUAGE=en_US:en
+ LC_ALL=C
+deps = -r{toxinidir}/requirements.txt
+ -r{toxinidir}/test-requirements.txt
+install_command = pip install -U {opts} {packages}
+usedevelop = True
+commands = python setup.py testr --slowest --testr-args='{posargs}'
+distribute = false
+
+[testenv:pep8]
+commands = flake8
+distribute = false
+
+[testenv:venv]
+commands = {posargs}
+
+[testenv:cover]
+commands = python setup.py testr --coverage --testr-args='{posargs}'
+
+[tox:jenkins]
+downloadcache = ~/cache/pip
+
+[flake8]
+ignore = E126,H703
+show-source = true
+builtins = _
+exclude=.venv,.git,.tox,dist,doc,*lib/python*,*egg,tools