summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Hellmann <doug@doughellmann.com>2018-04-13 16:13:58 -0400
committerDoug Hellmann <doug@doughellmann.com>2018-04-13 16:13:58 -0400
commit674ced35dcfbd0a9eee03f5cda96228b797e6a6f (patch)
tree36340a7f8b70c074ea23d3e24776785e5ae327f7
parent113a2dddddf6a67d0a2b69d94eef325e39520ac8 (diff)
downloadosprofiler-674ced35dcfbd0a9eee03f5cda96228b797e6a6f.tar.gz
set default python to python3
Set the default python to python3 except for the py27 environment. We have to set that explicitly to override the new default. Change-Id: I1b90426757130f9e8f32eb4882746bb44b3cf1e3 Signed-off-by: Doug Hellmann <doug@doughellmann.com>
-rw-r--r--tox.ini4
1 files changed, 4 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
index 8d33520..19e01ce 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,6 +4,7 @@ skipsdist = True
envlist = py35,py27,pep8
[testenv]
+basepython = python3
setenv = VIRTUAL_ENV={envdir}
LANG=en_US.UTF-8
LANGUAGE=en_US:en
@@ -16,6 +17,9 @@ usedevelop = True
commands = python setup.py testr --slowest --testr-args='{posargs}'
distribute = false
+[testenv:py27]
+basepython = python2.7
+
[testenv:functional]
basepython = python2.7
setenv = {[testenv]setenv}