summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini10
1 files changed, 5 insertions, 5 deletions
diff --git a/tox.ini b/tox.ini
index aad4538..064c4ed 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py35,py36,py37,pypy,pypy3,docs,readme,bandit,isort
+envlist = py35,py36,py37,py38,pypy,pypy3,docs,readme,bandit,isort
[testenv]
deps=
@@ -11,7 +11,7 @@ commands=
# tox -e docs to mimick readthedocs build.
# as of today, RTD is using python3.6 and doesn't run "setup.py install"
[testenv:docs]
-basepython=python3.6
+basepython=python3.8
skipsdist=True
deps=
sphinx
@@ -22,21 +22,21 @@ commands=make clean html
# tox -e readme to mimick PyPI long_description check
[testenv:readme]
-basepython=python3.7
+basepython=python3.8
deps=twine>=1.12.0
whitelist_externals=echo
commands=
twine check dist/*
[testenv:bandit]
-basepython=python3.7
+basepython=python3.8
skipsdist=True
deps=bandit
commands=bandit -b bandit.json -r oauthlib/
whitelist_externals=bandit
[testenv:isort]
-basepython = python3.7
+basepython = python3.8
usedevelop = false
deps = isort
changedir = {toxinidir}