summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAsif Saif Uddin (Auvi) <auvipy@gmail.com>2020-05-10 13:06:39 +0600
committerAsif Saif Uddin (Auvi) <auvipy@gmail.com>2020-05-10 13:06:39 +0600
commitf36492226e2e9640271ee4e2f84e82005ee2947a (patch)
tree3a39350c9ed1865ccec05a84448ce3cdd361555c
parent95533aff7ac28fe45e7454650cc9d04807a6b3e7 (diff)
downloadoauthlib-f36492226e2e9640271ee4e2f84e82005ee2947a.tar.gz
python 3.8
-rw-r--r--.travis.yml10
-rwxr-xr-xsetup.py1
-rw-r--r--tox.ini10
3 files changed, 11 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index fbf676b..4a6b86e 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,6 +1,6 @@
language: python
-python: 3.7
-dist: xenial
+python: 3.8
+dist: bionic
cache: pip
matrix:
include:
@@ -12,7 +12,7 @@ matrix:
env: TOXENV=py37
- python: 3.7
env: TOXENV=bandit
- - python: pypy3.5
+ - python: pypy3.6
env: TOXENV=pypy3
install:
- pip install -U setuptools
@@ -36,7 +36,7 @@ deploy:
on:
tags: true
all_branches: true
- condition: $TOXENV = py36
+ condition: $TOXENV = py38
repo: oauthlib/oauthlib
- provider: releases
api_key:
@@ -45,5 +45,5 @@ deploy:
on:
tags: true
all_branches: true
- condition: $TOXENV = py36
+ condition: $TOXENV = py38
repo: oauthlib/oauthlib
diff --git a/setup.py b/setup.py
index 6fada45..9218d7c 100755
--- a/setup.py
+++ b/setup.py
@@ -54,6 +54,7 @@ setup(
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3 :: Only',
'Programming Language :: Python :: Implementation',
'Programming Language :: Python :: Implementation :: CPython',
diff --git a/tox.ini b/tox.ini
index aad4538..064c4ed 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py35,py36,py37,pypy,pypy3,docs,readme,bandit,isort
+envlist = py35,py36,py37,py38,pypy,pypy3,docs,readme,bandit,isort
[testenv]
deps=
@@ -11,7 +11,7 @@ commands=
# tox -e docs to mimick readthedocs build.
# as of today, RTD is using python3.6 and doesn't run "setup.py install"
[testenv:docs]
-basepython=python3.6
+basepython=python3.8
skipsdist=True
deps=
sphinx
@@ -22,21 +22,21 @@ commands=make clean html
# tox -e readme to mimick PyPI long_description check
[testenv:readme]
-basepython=python3.7
+basepython=python3.8
deps=twine>=1.12.0
whitelist_externals=echo
commands=
twine check dist/*
[testenv:bandit]
-basepython=python3.7
+basepython=python3.8
skipsdist=True
deps=bandit
commands=bandit -b bandit.json -r oauthlib/
whitelist_externals=bandit
[testenv:isort]
-basepython = python3.7
+basepython = python3.8
usedevelop = false
deps = isort
changedir = {toxinidir}