summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Huot <JonathanHuot@users.noreply.github.com>2018-12-04 15:49:53 +0100
committerGitHub <noreply@github.com>2018-12-04 15:49:53 +0100
commit51c927b0641adcef6e5944c9a67ba1d7edc2eb68 (patch)
treeb1e3816d8a8b386facf5a9454f44e5879b21507f
parent64b308e8cba98d5769f3977cfd4bc559175ac882 (diff)
parent6b09a3130a5c64c5230c4f04361c4ec1b952537a (diff)
downloadoauthlib-51c927b0641adcef6e5944c9a67ba1d7edc2eb68.tar.gz
Merge pull request #621 from oauthlib/python-3.7
Support for Python 3.7
-rw-r--r--.gitignore2
-rw-r--r--.travis.yml8
-rwxr-xr-xsetup.py1
-rw-r--r--tox.ini2
4 files changed, 10 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index 6f24649..a3f5614 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.pyc
+.idea
*.sublime-project
*.sublime-workspace
*.swp
@@ -22,6 +23,7 @@ develop-eggs
pip-log.txt
# Unit test / coverage reports
+.cache
.coverage
.tox
coverage
diff --git a/.travis.yml b/.travis.yml
index f46bf43..e304ce6 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,4 +1,6 @@
language: python
+python: 3.7
+dist: xenial
sudo: false
cache: pip
matrix:
@@ -11,8 +13,10 @@ matrix:
env: TOXENV=py35
- python: 3.6
env: TOXENV=py36
- - python: pypy-5.3
- env: TOXENV=pypy
+ - python: 3.7
+ env: TOXENV=py37
+ - python: pypy3.5
+ env: TOXENV=pypy3
install:
- pip install -U setuptools
- pip install tox coveralls
diff --git a/setup.py b/setup.py
index 640bbe1..d2a27a0 100755
--- a/setup.py
+++ b/setup.py
@@ -64,6 +64,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: Implementation',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
diff --git a/tox.ini b/tox.ini
index c45f657..47237d8 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,py34,py35,py36,pypy,docs,readme
+envlist = py27,py34,py35,py36,py37,pypy,pypy3,docs,readme
[testenv]
deps=