summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalf Gommers <ralf.gommers@googlemail.com>2011-04-27 20:41:10 +0200
committerRalf Gommers <ralf.gommers@googlemail.com>2011-04-30 19:46:45 +0200
commit65bcb41240e260e5f8c85e4e30a8f6bc68c72567 (patch)
tree5dbac69dc54ddb52e7b16ee48be6d23c16310203
parent215c97ec7cd8b0350dd52bc5acbf993350586c53 (diff)
downloadnumpy-65bcb41240e260e5f8c85e4e30a8f6bc68c72567.tar.gz
REL: set version to 1.6.0rc1v1.6.0rc1
Also a small update to the release scripts.
-rw-r--r--pavement.py2
-rw-r--r--release.sh19
-rwxr-xr-xsetup.py4
3 files changed, 22 insertions, 3 deletions
diff --git a/pavement.py b/pavement.py
index 58d7a66d3..755e3bc41 100644
--- a/pavement.py
+++ b/pavement.py
@@ -102,7 +102,7 @@ RELEASE_NOTES = 'doc/release/1.6.0-notes.rst'
# Start/end of the log (from git)
LOG_START = 'v1.5.0'
-LOG_END = 'v1.6.0b1'
+LOG_END = 'v1.6.0rc1'
#-------------------------------------------------------
diff --git a/release.sh b/release.sh
index bb5a375db..5f1f31ebb 100644
--- a/release.sh
+++ b/release.sh
@@ -5,6 +5,17 @@
# downloads, i.e. two versions for Python 2.7. The Intel 32/64-bit version is
# for OS X 10.6+, the other dmg installers are for 10.3+ and are built on 10.5
+# Check we're using the correct g++/c++ for the 32-bit 2.6 version we build for
+# the docs and the 64-bit 2.7 dmg installer.
+# We do this because for Python 2.6 we use a symlink on the PATH to select
+# /usr/bin/g++-4.0, while for Python 2.7 we need the default 4.2 version.
+export PATH=~/Code/tmp/gpp40temp/:$PATH
+gpp="$(g++ --version | grep "4.0")"
+if [ -z "$gpp" ]; then
+ echo "Wrong g++ version, we need 4.0 to compile scipy with Python 2.6"
+ exit 1
+fi
+
# bootstrap needed to ensure we build the docs from the right scipy version
paver bootstrap
source bootstrap/bin/activate
@@ -19,6 +30,14 @@ paver pdf
paver sdist
export MACOSX_DEPLOYMENT_TARGET=10.6
+# Use GCC 4.2 for 64-bit OS X installer for Python 2.7
+export PATH=~/Code/tmp/gpp42temp/:$PATH
+gpp="$(g++ --version | grep "4.2")"
+if [ -z "$gpp" ]; then
+ echo "Wrong g++ version, we need 4.2 for 64-bit binary for Python 2.7"
+ exit 1
+fi
+
paver dmg -p 2.7 # 32/64-bit version
paver bdist_superpack -p 3.2
diff --git a/setup.py b/setup.py
index 6866dba56..0bf95e140 100755
--- a/setup.py
+++ b/setup.py
@@ -57,8 +57,8 @@ PLATFORMS = ["Windows", "Linux", "Solaris", "Mac OS-X", "Unix"]
MAJOR = 1
MINOR = 6
MICRO = 0
-ISRELEASED = False
-VERSION = '%d.%d.%db3' % (MAJOR, MINOR, MICRO)
+ISRELEASED = True
+VERSION = '%d.%d.%rc1' % (MAJOR, MINOR, MICRO)
# Return the git revision as a string
def git_version():