summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormattip <matti.picus@gmail.com>2020-07-14 22:58:22 +0300
committermattip <matti.picus@gmail.com>2020-07-14 23:00:09 +0300
commit24748cbc66a8ead55bde0e9ef344207f3b3c33cf (patch)
tree4c2445c4d7d5cd7e6e96f157f82c419c5cb6530b
parentf8ba31164868eae4c1b4ce78d7768dee1d58b443 (diff)
downloadnumpy-24748cbc66a8ead55bde0e9ef344207f3b3c33cf.tar.gz
Revert "MAINT: setuptools 49.2.0 emits a warning, avoid it"
-rw-r--r--numpy/distutils/__init__.py4
-rwxr-xr-xruntests.py3
-rwxr-xr-xsetup.py4
3 files changed, 1 insertions, 10 deletions
diff --git a/numpy/distutils/__init__.py b/numpy/distutils/__init__.py
index 528b76eb5..79974d1c2 100644
--- a/numpy/distutils/__init__.py
+++ b/numpy/distutils/__init__.py
@@ -18,9 +18,7 @@ LAPACK, and for setting include paths and similar build options, please see
``site.cfg.example`` in the root of the NumPy repository or sdist.
"""
-# from setuptools v49.2.0, setuptools warns if distutils is imported first,
-# so pre-emptively import setuptools
-import setuptools
+
# Must import local ccompiler ASAP in order to get
# customized CCompiler.spawn effective.
from . import ccompiler
diff --git a/runtests.py b/runtests.py
index 17620478d..beaf668d6 100755
--- a/runtests.py
+++ b/runtests.py
@@ -341,9 +341,6 @@ def build_project(args):
"""
- # from setuptools v49.2.0, setuptools warns if distutils is imported first,
- # so pre-emptively import setuptools
- import setuptools
import distutils.sysconfig
root_ok = [os.path.exists(os.path.join(ROOT_DIR, fn))
diff --git a/setup.py b/setup.py
index 46c24d543..2cd2bda02 100755
--- a/setup.py
+++ b/setup.py
@@ -219,10 +219,6 @@ class concat_license_files():
f.write(self.bsd_text)
-# from setuptools v49.2.0, setuptools warns if distutils is imported first,
-# so pre-emptively import setuptools. Eventually we can migrate to using
-# setuptools.command
-import setuptools
from distutils.command.sdist import sdist
class sdist_checked(sdist):
""" check submodules on sdist to prevent incomplete tarballs """