summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2019-12-03 18:06:17 -0800
committerGitHub <noreply@github.com>2019-12-03 18:06:17 -0800
commit766eb34aaad10bbd2ead50e4aef438192fe87ad4 (patch)
treeca3354b604387d1b0b9dca307c84f59cb3e3fbf4
parentfdd8395f21a252373ff17fd43185c42e040c1b64 (diff)
parentfbcb58ca2c17217f5dc85cb669ea651b7799b60c (diff)
downloadnumpy-766eb34aaad10bbd2ead50e4aef438192fe87ad4.tar.gz
Merge pull request #15042 from charris/post-1.18.x-branch-update
REL: Update master after 1.18.x branch.
-rw-r--r--.travis.yml1
-rw-r--r--azure-pipelines.yml5
-rw-r--r--doc/release/upcoming_changes/14794.deprecation.rst7
-rw-r--r--doc/source/release.rst1
-rw-r--r--numpy/core/code_generators/cversions.txt1
-rw-r--r--numpy/core/include/numpy/numpyconfig.h1
-rwxr-xr-xsetup.py7
7 files changed, 6 insertions, 17 deletions
diff --git a/.travis.yml b/.travis.yml
index 64b7be051..4afac959d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -43,7 +43,6 @@ matrix:
- stage: Initial tests
python: 3.8
- - python: 3.5
- python: 3.6
- python: 3.7
diff --git a/azure-pipelines.yml b/azure-pipelines.yml
index 9e1e52952..29fc6c614 100644
--- a/azure-pipelines.yml
+++ b/azure-pipelines.yml
@@ -156,11 +156,6 @@ stages:
PYTHON_ARCH: 'x86'
TEST_MODE: fast
BITS: 32
- Python35-64bit-full:
- PYTHON_VERSION: '3.5'
- PYTHON_ARCH: 'x64'
- TEST_MODE: full
- BITS: 64
Python36-64bit-full:
PYTHON_VERSION: '3.6'
PYTHON_ARCH: 'x64'
diff --git a/doc/release/upcoming_changes/14794.deprecation.rst b/doc/release/upcoming_changes/14794.deprecation.rst
deleted file mode 100644
index b84bc1c61..000000000
--- a/doc/release/upcoming_changes/14794.deprecation.rst
+++ /dev/null
@@ -1,7 +0,0 @@
-Deprecate automatic ``dtype=object`` for ragged input
------------------------------------------------------
-Calling ``np.array([[1, [1, 2, 3]])`` will issue a ``DeprecationWarning`` as
-per `NEP 34`_. Users should explicitly use ``dtype=object`` to avoid the
-warning.
-
-.. _`NEP 34`: https://numpy.org/neps/nep-0034.html
diff --git a/doc/source/release.rst b/doc/source/release.rst
index 0343275a5..26373ad07 100644
--- a/doc/source/release.rst
+++ b/doc/source/release.rst
@@ -5,6 +5,7 @@ Release Notes
.. toctree::
:maxdepth: 3
+ 1.19.0 <release/1.19.0-notes>
1.18.0 <release/1.18.0-notes>
1.17.4 <release/1.17.4-notes>
1.17.3 <release/1.17.3-notes>
diff --git a/numpy/core/code_generators/cversions.txt b/numpy/core/code_generators/cversions.txt
index 72d2af8b9..5daa52d79 100644
--- a/numpy/core/code_generators/cversions.txt
+++ b/numpy/core/code_generators/cversions.txt
@@ -49,4 +49,5 @@
# Add PyUFunc_FromFuncAndDataAndSignatureAndIdentity to ufunc_funcs_api.
# Version 13 (NumPy 1.17) No change.
# Version 13 (NumPy 1.18) No change.
+# Version 13 (NumPy 1.19) No change.
0x0000000d = 5b0e8bbded00b166125974fc71e80a33
diff --git a/numpy/core/include/numpy/numpyconfig.h b/numpy/core/include/numpy/numpyconfig.h
index 4bca82f9f..4df4ea438 100644
--- a/numpy/core/include/numpy/numpyconfig.h
+++ b/numpy/core/include/numpy/numpyconfig.h
@@ -40,5 +40,6 @@
#define NPY_1_16_API_VERSION 0x00000008
#define NPY_1_17_API_VERSION 0x00000008
#define NPY_1_18_API_VERSION 0x00000008
+#define NPY_1_19_API_VERSION 0x00000008
#endif
diff --git a/setup.py b/setup.py
index 46c95d6e6..43f9521b5 100755
--- a/setup.py
+++ b/setup.py
@@ -27,8 +27,8 @@ import subprocess
import textwrap
-if sys.version_info[:2] < (3, 5):
- raise RuntimeError("Python version >= 3.5 required.")
+if sys.version_info[:2] < (3, 6):
+ raise RuntimeError("Python version >= 3.6 required.")
import builtins
@@ -41,7 +41,6 @@ License :: OSI Approved
Programming Language :: C
Programming Language :: Python
Programming Language :: Python :: 3
-Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
@@ -56,7 +55,7 @@ Operating System :: MacOS
"""
MAJOR = 1
-MINOR = 18
+MINOR = 19
MICRO = 0
ISRELEASED = False
VERSION = '%d.%d.%d' % (MAJOR, MINOR, MICRO)