summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormattip <matti.picus@gmail.com>2019-03-01 09:05:12 +0200
committermattip <matti.picus@gmail.com>2019-03-01 09:12:40 +0200
commit6f1b386e3ae144ba348e420b0fccccd4fc62ce69 (patch)
treeb9e20b01de5223ce962c647f90b15fe8535b9974
parenta72f061ede7cf2058829668a4f5d110dec265f1c (diff)
downloadnumpy-6f1b386e3ae144ba348e420b0fccccd4fc62ce69.tar.gz
DOC: revert #13058 and fix Makefile
-rw-r--r--doc/Makefile8
-rw-r--r--numpy/lib/function_base.py6
2 files changed, 9 insertions, 5 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 7c1dde90c..cb8f8a397 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -1,9 +1,13 @@
# Makefile for Sphinx documentation
#
-# This needs to be major.minor, just "3" doesn't work - it will result in
+# PYVER needs to be major.minor, just "3" doesn't work - it will result in
# issues with the amendments to PYTHONPATH and install paths (see DIST_VARS).
-export PYVER=`python3 -c 'import sys; print("{0}.{1}".format(*sys.version_info[:2]))'`
+
+# Use explicit "version_info" indexing since make cannot handle colon characters, and
+# evaluate it now to allow easier debugging when printing the varaible
+
+PYVER:=$(shell python3 -c 'from sys import version_info as v; print("{0}.{1}".format(v[0], v[1]))')
PYTHON = python$(PYVER)
# You can set these variables from the command line.
diff --git a/numpy/lib/function_base.py b/numpy/lib/function_base.py
index 2a66bdb3a..b61a64b8e 100644
--- a/numpy/lib/function_base.py
+++ b/numpy/lib/function_base.py
@@ -1292,9 +1292,9 @@ def interp(x, xp, fp, left=None, right=None, period=None):
The x-coordinates at which to evaluate the interpolated values.
xp : 1-D sequence of floats
- The x-coordinates of the data points, must be strictly increasing if
- argument `period` is not specified. Otherwise, `xp` is internally sorted
- after normalizing the periodic boundaries with ``xp = xp % period``.
+ The x-coordinates of the data points, must be increasing if argument
+ `period` is not specified. Otherwise, `xp` is internally sorted after
+ normalizing the periodic boundaries with ``xp = xp % period``.
fp : 1-D sequence of float or complex
The y-coordinates of the data points, same length as `xp`.