summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormattip <matti.picus@gmail.com>2021-10-03 09:38:09 +0300
committermattip <matti.picus@gmail.com>2021-10-03 09:38:09 +0300
commit161ac32de7239e3bf3dae1b4cf66d76386ce5aa8 (patch)
treef173438457a3aad32c62891b89aac2c4fff08053
parent8262dc987e8edba4fb261fa5f1e13ed6729d0a8c (diff)
downloadnumpy-161ac32de7239e3bf3dae1b4cf66d76386ce5aa8.tar.gz
use venv instead of virtualenv
-rwxr-xr-xtools/travis-before-install.sh5
-rwxr-xr-xtools/travis-test.sh4
2 files changed, 4 insertions, 5 deletions
diff --git a/tools/travis-before-install.sh b/tools/travis-before-install.sh
index 65aa4ad13..056e97472 100755
--- a/tools/travis-before-install.sh
+++ b/tools/travis-before-install.sh
@@ -22,13 +22,12 @@ pushd builds
# Build into own virtualenv
# We therefore control our own environment, avoid travis' numpy
-pip install -U virtualenv
if [ -n "$USE_DEBUG" ]
then
- virtualenv --python=$(which python3-dbg) venv
+ python3-dbg -m venv venv
else
- virtualenv --python=python venv
+ python -m venv venv
fi
source venv/bin/activate
diff --git a/tools/travis-test.sh b/tools/travis-test.sh
index 4667db991..b395942fb 100755
--- a/tools/travis-test.sh
+++ b/tools/travis-test.sh
@@ -165,7 +165,7 @@ if [ -n "$USE_WHEEL" ] && [ $# -eq 0 ]; then
fi
$PYTHON setup.py build --warn-error build_src --verbose-cfg bdist_wheel
# Make another virtualenv to install into
- virtualenv --python=`which $PYTHON` venv-for-wheel
+ $PYTHON -m venv venv-for-wheel
. venv-for-wheel/bin/activate
# Move out of source directory to avoid finding local numpy
pushd dist
@@ -181,7 +181,7 @@ elif [ -n "$USE_SDIST" ] && [ $# -eq 0 ]; then
export CFLAGS=$CFLAGS" -Wno-sign-compare -Wno-unused-result"
$PYTHON setup.py sdist
# Make another virtualenv to install into
- virtualenv --python=`which $PYTHON` venv-for-wheel
+ $PYTHON -m venv venv-for-wheel
. venv-for-wheel/bin/activate
# Move out of source directory to avoid finding local numpy
pushd dist