summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharles Harris <charlesr.harris@gmail.com>2020-12-12 08:17:01 -0700
committerCharles Harris <charlesr.harris@gmail.com>2020-12-12 08:17:01 -0700
commitca11e4e2ebde67743c3ce09ccd265ffd855dbf4f (patch)
tree9cd207fea881556ae034442b4e98840742316e99
parentfed2509471e77e0357c5252e69fc6159881f6cb2 (diff)
downloadnumpy-ca11e4e2ebde67743c3ce09ccd265ffd855dbf4f.tar.gz
BUG: Replace f-string in root setup.py
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 5e8290a7a..e54328e06 100755
--- a/setup.py
+++ b/setup.py
@@ -47,11 +47,11 @@ if sys.version_info[:2] < (3, 7):
# The first version not in the `Programming Language :: Python :: ...` classifiers above
if sys.version_info >= (3, 10):
+ fmt = "NumPy {} may not yet support Python {}.{}."
warnings.warn(
- f"NumPy {VERSION} may not yet support Python "
- f"{sys.version_info.major}.{sys.version_info.minor}.",
- RuntimeWarning,
- )
+ fmt.format(VERSION, *sys.version_info[:2]),
+ RuntimeWarning)
+ del fmt
# BEFORE importing setuptools, remove MANIFEST. Otherwise it may not be
# properly updated when the contents of directories change (true for distutils,